Subject: [pgAdmin] [patch] RM5319 [Code Coverage] Improve API test cases for Server module

From: Rahul Shirsat <[email-masked]>
Date: Tue, 16 Mar 2021 11:51:09 +0530

Hi Hackers,

Please find the patch for code coverage to improve test cases for server
modules.

Also a minor issue of server creation when created along with Advanced Tab
setting passfile keeping auto connect disable is fixed along with this
patch.

-- 
*Rahul Shirsat*
Senior Software Engineer | EnterpriseDB Corporation.

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 17 Mar 2021 12:56:44 +0530

Hi Rahul

No improvement in the coverage after applying your patch. Attached is the
HTML file to show which function/code not covered.
Please try to cover those functions/codes if possible and then send the
patch.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Rahul Shirsat <[email-masked]>
Date: Wed, 24 Mar 2021 15:13:20 +0530

Hi Akshay,

Please find the updated patch which covers 75% of code coverage for Server
mode & 68% for Desktop mode.

On Wed, Mar 17, 2021 at 12:56 PM Akshay Joshi <[email-masked]>
wrote:

>> Also a minor issue of server creation when created along with Advanced
>> Tab setting passfile keeping auto connect disable is fixed along with this
>> patch.
>>
>> --
>> *Rahul Shirsat*

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 30 Mar 2021 11:16:18 +0530

Thanks, patch applied.

On Wed, Mar 24, 2021 at 3:13 PM Rahul Shirsat <
[email-masked]> wrote:

> On Wed, Mar 17, 2021 at 12:56 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Rahul
>>