Subject: [pgAdmin][Patch] - Feature #6395 - Feature request: Log Rotation

From: Yogesh Mahajan <[email-masked]>
Date: Tue, 25 May 2021 10:53:34 +0530

Hi,

Please find the attached patch which rotates the pgadmin log file with
context to the parameters specified in the config file.

# Log rotation setting
LOG_ROTATION_SIZE = 10  # In MBs
LOG_ROTATION_AGE = 1440  # In minutes
LOG_ROTATION_MAX_LOGS = 90  # Maximum number of backups to retain

Thanks,
Yogesh Mahajan
EnterpriseDB

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 25 May 2021 13:09:33 +0530

Hi Yogesh

Following are the review comments:

   - LOG_ROTATION_MAX_LOGS should be renamed to LOG_ROTATION_MAX_LOG_FILES
   - Rollover file name should have '.log' extension at the end instead of "
   pgadmin4.log.2021-05-25_12-17-43"
   - Add comments in the 'enhanced_log_rotation.py' file.
   -  'enhanced_log_rotation.py' file line no 23 should be "max_bytes =
   max_bytes * 1024 * 1024" instead of "max_bytes = max_bytes * 1000000"

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Yogesh Mahajan <[email-masked]>
Date: Tue, 25 May 2021 16:58:42 +0530

Hello,

Please find the attached file incorporated with the above comments except
the 2nd one.

Thanks,
Yogesh Mahajan
EnterpriseDB

On Tue, May 25, 2021 at 1:09 PM Akshay Joshi <[email-masked]>
wrote:

>    - Rollover file name should have '.log' extension at the end instead
>    of "pgadmin4.log.2021-05-25_12-17-43"

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 25 May 2021 20:19:38 +0530

Thanks, patch applied.

On Tue, May 25, 2021 at 4:59 PM Yogesh Mahajan <
[email-masked]> wrote:

> On Tue, May 25, 2021 at 1:09 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Yogesh
>>