Subject: [pgAdmin4][RM#4858] Allow user to reconnect to DB server when connection is drop

From: Murtuza Zabuawala <[email-masked]>
Date: Fri, 10 Apr 2020 19:01:00 +0530

Hi,

Upon downloading the csv file, we used the prompt for re-connecting to the
database server when there is a database server connection issue. Currently
the user tries to download CSV and there is a connection issue then it is
showing a python exception error.

Steps:
1) Open query tool
2) Execute -> SELECT 1,2,3
3) Disconnect from server from browser tree
4) Click on Download CSV button

Current: Python exception error
Expected: It should display dialog to reconnect the server.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 13 Apr 2020 14:28:46 +0530

Hi Murtuza

The issue has been fixed with your patch, but there is an existing issue
discover with the fix.
After disconnecting the server and click on Download CSV button
confirmation dialog comes and user needs to click twice.
Following error observed in the browser:

sqleditor.js?ver=42000:1 Uncaught TypeError: Cannot read property 'apply'
of undefined
    at Object.<anonymous> (sqleditor.js?ver=42000:1)
    at Object.callback (vendor.others.js?ver=42000:2)
    at Tt (vendor.others.js?ver=42000:2)
    at Object.Ct (vendor.others.js?ver=42000:2)
    at HTMLDivElement.<anonymous> (vendor.others.js?ver=42000:2)

If possible can you please fix the above and resend the combined patch.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Murtuza Zabuawala <[email-masked]>
Date: Wed, 15 Apr 2020 12:22:36 +0530

Hi Akshay,

PFA updated patch.

On Mon, Apr 13, 2020 at 2:28 PM Akshay Joshi <[email-masked]>
wrote:

>> Upon downloading the csv file, we used the prompt for re-connecting to
>> the database server when there is a database server connection issue.
>> Currently the user tries to download CSV and there is a connection issue
>> then it is showing a python exception error.
>>
>> Steps:
>> 1) Open query tool

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 15 Apr 2020 16:46:49 +0530

Thanks, patch applied.

On Wed, Apr 15, 2020 at 12:22 PM Murtuza Zabuawala <
[email-masked]> wrote:

> On Mon, Apr 13, 2020 at 2:28 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Murtuza
>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*