Subject: [pgAdmin][RM5867]:Some properties are not getting updated correctly if the server is shared server.

From: Pradip Parkale <[email-masked]>
Date: Wed, 30 Sep 2020 11:00:16 +0530

Hi Hackers,

Please find the attached patch for the below issues.

   1. Shared with all? changed to 'Shared?'.
   2. Hide shared server? changed to 'Hide shared servers?'.
   3. Some properties of the base server were getting updated if the user
   updated the shared server properties so I fixed this issue.
   4. Fixed an issue where 'Later' and 'Refresh' button labels were getting
   override on disconnect server confirmation dialogue.
   5. If the user shares an auto-detected server and other user log-in then
   the auto-detected server of the second user will not be visible, the second
   user will see a shared auto-detected server.

-- 
Thanks & Regards,
Pradip Parkale
Software Engineer | EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 30 Sep 2020 12:34:33 +0530

Thanks, patch applied.

On Wed, Sep 30, 2020 at 11:00 AM Pradip Parkale <
[email-masked]> wrote:

>    4. Fixed an issue where 'Later' and 'Refresh' button labels were
>    getting override on disconnect server confirmation dialogue.
>    5. If the user shares an auto-detected server and other user log-in
>    then the auto-detected server of the second user will not be visible, the
>    second user will see a shared auto-detected server.
>
>
> --
> Thanks & Regards,
> Pradip Parkale

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Pradip Parkale <[email-masked]>
Date: Wed, 30 Sep 2020 22:55:50 +0530

Hi Akshay,
Please find the attached patch for the API failure issue.

On Wed, Sep 30, 2020 at 12:34 PM Akshay Joshi <[email-masked]>
wrote:

>>    3. Some properties of the base server were getting updated if the
>>    user updated the shared server properties so I fixed this issue.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 1 Oct 2020 13:31:40 +0530

Thanks, patch applied.

On Wed, Sep 30, 2020 at 10:56 PM Pradip Parkale <
[email-masked]> wrote:

> On Wed, Sep 30, 2020 at 12:34 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Thanks, patch applied.
>>