Subject: Patch for SonarQube fixes.

From: Nikhil Mohite <[email-masked]>
Date: Mon, 18 Jan 2021 11:15:39 +0530

Hi Team,

I have fixed a few sonarQube issues, PFA patch
Details as follows:

1. Preferences:

   - Refactor this function to reduce its Cognitive Complexity from 18 to
   the 15 allowed.
   - Merge this if statement with the enclosing one.
   - Define a constant instead of duplicating this literal 'tab settings' 5
   times.

2. Connection:

   - Remove this unneeded "pass".

3. Sqleditor:

   - Remove this useless assignment to variable "msgDiv".

4. Debugger:

   - Review this useless assignment: "index" already holds the assigned
   value along all execution paths.
   - 'label' is already declared in the upper scope.
   - 'label' is already declared in the upper scope.
   - 'browser_preferences' is already declared in the upper scope.

5. FileManager:

   - 'path' is already declared in the upper scope.

-- 
*Thanks & Regards,*
*Nikhil Mohite*
*Software Engineer.*
*EDB Postgres* <https://www.enterprisedb.com/>
*Mob.No: +91-7798364578.*

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 18 Jan 2021 13:09:41 +0530

Thanks, patch applied.

On Mon, Jan 18, 2021 at 11:15 AM Nikhil Mohite <
[email-masked]> wrote:

>    - Define a constant instead of duplicating this literal 'tab settings'
>    5 times.
>
> 2. Connection:
>

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*