Subject: [pgAdmin]: Patch for SonarQube fixes.

From: Nikhil Mohite <[email-masked]>
Date: Mon, 1 Mar 2021 16:12:18 +0530

Hi Team,

I have fixed a few sonarQube issues, PFA patch
Details as follows:

1. Back-form  (backform.pgadmin.js):

   - TypeError can be thrown as "$tabContent" might be null or undefined
   here.

2. User Management (user_management.js):

   - 'self' is already declared in the upper scope.
   - 'res' is already declared in the upper scope.
   - 'self' is already declared in the upper scope.
   - 'ownershipModel' is already declared in the upper scope.

-- 
*Thanks & Regards,*
*Nikhil Mohite*
*Software Engineer.*
*EDB Postgres* <https://www.enterprisedb.com/>
*Mob.No: +91-7798364578.*

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 1 Mar 2021 16:37:28 +0530

Hi Nikhil

You forgot to attach the patch :)

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Nikhil Mohite <[email-masked]>
Date: Mon, 1 Mar 2021 16:42:39 +0530

Hi Akshay,

Sorry for the inconvenience, Please find the attached patch.

Regards,
Nikhil Mohite.

On Mon, Mar 1, 2021 at 4:37 PM Akshay Joshi <[email-masked]>
wrote:

> On Mon, Mar 1, 2021 at 4:12 PM Nikhil Mohite <
> [email-masked]> wrote:
>
>> Hi Team,
>>

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 1 Mar 2021 18:00:46 +0530

Thanks, patch applied.

On Mon, Mar 1, 2021 at 4:42 PM Nikhil Mohite <[email-masked]>
wrote:

>>>    - TypeError can be thrown as "$tabContent" might be null or
>>>    undefined here.
>>>