Subject: [pgAdmin][RM4855] Renaming a file removes the file extension

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 28 Sep 2020 18:07:47 +0530

Hi Hackers,

Attached is the patch to fix a bug where extension file extension is
stripped on renaming a file.
Pleasure review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 8 Oct 2020 18:26:52 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 8 Oct 2020 18:33:45 +0530

Hi,

Attached patch will add the .sql when saving a file and and format -> sql
selected, no matter what the file name is.
Please review.

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 9 Oct 2020 11:53:36 +0530

Thanks, patch applied.

---

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 12 Oct 2020 17:54:53 +0530

Hi Hackers,

Attached is a patch to improve this further. It will skip adding the
extension if the file already has the extension selected from the format
dropdown.
Please review.

On Fri, Oct 9, 2020 at 11:53 AM Akshay Joshi <[email-masked]>
wrote:

>> On Thu, Oct 8, 2020 at 6:27 PM Akshay Joshi <
>> [email-masked]> wrote:
>>
>>> Thanks, patch applied.
>>>

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 12 Oct 2020 18:04:35 +0530

Thanks, patch applied.

On Mon, Oct 12, 2020 at 5:55 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Fri, Oct 9, 2020 at 11:53 AM Akshay Joshi <
>>> Attached patch will add the .sql when saving a file and and format ->
>>> sql selected, no matter what the file name is.
>>> Please review.
>>>