Subject: [pgAdmin4][RM3693] Message "Error saving properties Click on Detail" displayed if user create server group with same name

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 15 Jan 2019 11:20:34 +0530

Hi Hackers,

Attached is the patch to fix back end exception which is common and
mentioned in SQLAlchemy FAQ -
https://docs.sqlalchemy.org/en/latest/faq/sessions.html#this-session-s-transaction-has-been-rolled-back-due-to-a-previous-exception-during-flush-or-similar
The fix is as per the FAQ answer.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB Software Solutions | Pune
"Don't Complain about Heat, Plant a tree"

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 15 Jan 2019 18:40:07 +0530

Thanks patch applied.

-- 
*Akshay Joshi*

*Sr. Software Architect *

*Phone: +91 20-3058-9517Mobile: +91 976-788-8246*