Subject: [pgAdmin][RM4925] Missing spinner from process watcher

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 14 Nov 2019 16:45:46 +0530

Hi Hackers,

Attached is the patch to show some text on process watcher till the initial
logs are loaded. Adding a spinner was not possible due to the complex DOM
structure of the logs window. Below is the screenshot:

-- 
Thanks and Regards,
Aditya Toshniwal
Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Dave Page <[email-masked]>
Date: Thu, 14 Nov 2019 11:29:35 +0000

Hi

On Thu, Nov 14, 2019 at 11:16 AM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Hackers,
>
> Attached is the patch to show some text on process watcher till the
> initial logs are loaded. Adding a spinner was not possible due to the
> complex DOM structure of the logs window. Below is the screenshot:
>

A definite improvement - but can we not consistently display the logs in
realtime? I've noticed in the past that sometimes that happens, but other
times they're only displayed when the process completes. I haven't yet had
a chance to figure out exactly what circumstances each happens in.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 14 Nov 2019 17:43:44 +0530

Hi Dave,

> a chance to figure out exactly what circumstances each happens in.
It is updated in real time. This is what happens when you open the process
watcher and the logs web service is accessed to get the initial logs. After
that, the logs are pulled and appended at regular intervals.

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 15 Nov 2019 12:13:05 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*