Subject: [pgAdmin][patch] Use unique DB name in ERD API test cases

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 3 Feb 2021 16:00:54 +0530

Hi Hackers,

Attached is the patch to use unique DB names in ERD API test cases to avoid
conflict when running test cases in parallel.
Please review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 3 Feb 2021 16:49:44 +0530

Thanks, patch applied.

On Wed, Feb 3, 2021 at 4:01 PM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Hackers,
>
> Attached is the patch to use unique DB names in ERD API test cases to
> avoid conflict when running test cases in parallel.
> Please review.
>
> --
> Thanks,
> Aditya Toshniwal

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 4 Feb 2021 15:01:54 +0530

Hi,

Seems like the test cases are still failing on the build machines.
Attached is the patch to make the connection ids unique by using random.
Please review.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 4 Feb 2021 16:16:33 +0530

Thanks, patch applied.