Subject: [pgAdmin][RM6794]: Provide functionality to disable/enable rules

From: Pradip Parkale <[email-masked]>
Date: Mon, 11 Oct 2021 19:37:09 +0530

Hi Hackers,

Please find the updated patch for #6794 Provide functionality to
disable/enable rules.

This patch also includes the fix for #6870 Unable to delete server group if
first server group has shared server.

-- 
Thanks & Regards,
Pradip Parkale
Software Engineer | EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 12 Oct 2021 17:37:08 +0530

Hi Pradip

You forgot to implement the following:
ENABLE REPLICA RULE rewrite_rule_name
ENABLE ALWAYS RULE rewrite_rule_name

It is just like a trigger, you need to get the drop-down in edit mode.
Please update the documentation and screenshot as well.

On Mon, Oct 11, 2021 at 7:37 PM Pradip Parkale <
[email-masked]> wrote:

> This patch also includes the fix for #6870 Unable to delete server group
> if first server group has shared server.
>
> --
> Thanks & Regards,
> Pradip Parkale

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Pradip Parkale <[email-masked]>
Date: Wed, 13 Oct 2021 16:50:33 +0530

Hi Akshay,

Please find the updated patch.

> ENABLE ALWAYS RULE rewrite_rule_name
Fixed.

> Please update the documentation and screenshot as well.
Fixed.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 14 Oct 2021 11:47:20 +0530

Thanks, the patch applied.

On Wed, Oct 13, 2021 at 4:50 PM Pradip Parkale <
[email-masked]> wrote:

> On Tue, Oct 12, 2021 at 5:37 PM Akshay Joshi <
> [email-masked]> wrote:
>
>>  Hi Pradip
>>