Subject: [pgAdmin4][RM#2813] Do not prompt for database server password once user saves it

From: Murtuza Zabuawala <[email-masked]>
Date: Thu, 9 Apr 2020 19:00:46 +0530

Hi,

There was an issue where the user used trust mode to connect to the
database server and saves a blank password, and next time when the user
tries to connect from pgadmin, pgadmin again asks for the password.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 10 Apr 2020 14:17:11 +0530

Hi Murtuza

The issue is still reproducible when you add a new server with Save
Password is checked. Disconnect the server and connect again, it ask for
the Password.
Please fix the above and resend the patch.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Murtuza Zabuawala <[email-masked]>
Date: Fri, 10 Apr 2020 16:00:00 +0530

Hi Akshay,

Thanks for reviewing, PFA updated patch, it was a minor logical conditional
issue.

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 10 Apr 2020 17:37:49 +0530

Thanks, patch applied.

On Fri, Apr 10, 2020 at 4:00 PM Murtuza Zabuawala <
[email-masked]> wrote:

> Hi Akshay,
>
> Thanks for reviewing, PFA updated patch, it was a minor logical
> conditional issue.
>
>
> --
> Regards,
> Murtuza Zabuawala
> On Fri, Apr 10, 2020 at 2:17 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Murtuza
>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*