Subject: Re: Macro Support UI Design

From: Chethana Kumar <[email-masked]>
Date: Thu, 27 Aug 2020 17:58:23 +0530

Hi Khushboo,

I have a couple of opinions -

- Can we place "Name" in the first position and then "Key" at the second?
- I think 'delete' icon suites more than 'clear icon'
- Can we have the dropdown menu as below? As you can see user can select
the "entered query from the query editor" then directly press "New Macro"
which saves the user time and energy too.  Please correct me if this is not
something logical working one.

---
Chethana Kumar

On Thu, Aug 27, 2020 at 5:37 PM Khushboo Vashi <
[email-masked]> wrote:

>
>
> On Thu, Aug 27, 2020 at 5:34 PM Dave Page <[email-masked]>
> wrote:
>
>> I think you sent this to the wrong mailing list.
>>
> Forwarded to pgadmin-hackers. :)
>
>>
>> On Thu, Aug 27, 2020 at 11:08 AM Khushboo Vashi <
>> [email-masked]> wrote:
>>
>>> Hi Team,
>>>
>>> I have started working on the feature #1402: Macro support like pgAdmin
>>> 3.
>>>
>>> I am thinking of the design below.
>>>
>>>
>>> - On clicking upon the Manage Macro, the dialogue will be opened
>>> - In the grid, I have provided Clear Icon instead of Delete as we will
>>> have all the supported macro listed with the shortcut key and the key will
>>> not be editable, so no need to delete the row.
>>> - Add button will be disabled or can be removed.
>>>
>>> - All the configured macros by the user will be displayed in the list
>>> below the Manage Macros menu item and on clicking on the particular macro,
>>> it will be executed in the SQL Editor
>>>
>>> Please provide feedback/suggestions.
>>>
>>> Thanks,
>>> Khushboo
>>>
>>
>>
>> --
>> Dave Page
>> VP & Chief Architect, Database Infrastructure
>> EDB: http://www.enterprisedb.com
>>
>> Blog: http://pgsnake.blogspot.com
>> Twitter: @pgsnake
>>
>

---

From: Khushboo Vashi <[email-masked]>
Date: Thu, 27 Aug 2020 18:20:55 +0530

Hi Chethana,

> - Can we place "Name" in the first position and then "Key" at the second?
Basically the key is going to be the non-editable field (unique key) and
the user can not change it. Users can only change name and SQL, so the key
is in first place.

> - I think 'delete' icon suites more than 'clear icon'
We use the delete icon to completely delete the row from the grid but here
we are not going to delete the row, only clearing the name and SQL fields
for the selected row. So, the macro details against that key will be
removed from the database but the key remains in the database.

> something logical working one.
Sure, we can have a drop down menu as you suggested but not sure about the
selecting the entered query and can use that directly in the New Macro
dialog as we will have a list of macros.

Thanks,
Khushboo

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 27 Aug 2020 18:55:08 +0530

Hi Chethana

> removed from the database but the key remains in the database.

    For the above two points, I agree with Khushboo.

> dialog as we will have a list of macros.

    I will go with "Manage macros..." instead of "<New Macro>" as it opens
the dialog where the user can edit the Query and Name, we are not adding
any new keyboard shortcuts. Refer to the pgAdmin 3 screenshot.

    Regarding select the query from the query editor and click on the menu
option won't solve the purpose as we don't know which shortcut key to map
this query.

>>>>> I have started working on the feature #1402: Macro support like
>>>>> pgAdmin 3.
>>>>>

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Chethana Kumar <[email-masked]>
Date: Tue, 1 Sep 2020 11:53:49 +0530

Hi Team,

I am sort of ok with Khushboo's design solution which re-uses the existing
UI element called sub-node control.

At the same time, I wanted to increase the ease of use and less cluttered
there.
So for that, I had to get rid of the subnode control to come up with the
new thoughts on to it.

I have come up with 2 samples where they have a different way of *clearing
multiple shortcut keys.*

Sample1-

Sample2

*Annotation-*

*Functionality Animation -*

I have also attached icon for '*macro*' and I have a small correction with
the dropdown menu as shown below -

Correction as *Manage macro... *in place of *Manage Macro*

I need your comments on the same.

----
Chethana Kumar

On Thu, Aug 27, 2020 at 6:55 PM Akshay Joshi <[email-masked]>
wrote:

>> We use the delete icon to completely delete the row from the grid but
>> here we are not going to delete the row, only clearing the name and SQL
>> fields for the selected row. So, the macro details against that key will be
>> Sure, we can have a drop down menu as you suggested but not sure about
>> the selecting the entered query and can use that directly in the New Macro
>>>>>> - In the grid, I have provided Clear Icon instead of Delete as we
>>>>>> will have all the supported macro listed with the shortcut key and the key
>>>>>> will not be editable, so no need to delete the row.

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 1 Sep 2020 11:57:19 +0530

Hi Chethana

I like Sample 2 (with checkboxes).

On Tue, Sep 1, 2020 at 11:54 AM Chethana Kumar <
[email-masked]> wrote:

> I have also attached icon for '*macro*' and I have a small correction
> with the dropdown menu as shown below -
>
>
> On Thu, Aug 27, 2020 at 6:55 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Chethana
>>
>>     I will go with "Manage macros..." instead of "<New Macro>" as it
>> opens the dialog where the user can edit the Query and Name, we are not
>> adding any new keyboard shortcuts. Refer to the pgAdmin 3 screenshot.
>>
>>     Regarding select the query from the query editor and click on the
>> menu option won't solve the purpose as we don't know which shortcut key to
>> map this query.
>>
>>>
>>> Thanks,
>>> Khushboo
>>>
>>>>
>>>>
>>>> ---
>>>> Chethana Kumar
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>>>> - All the configured macros by the user will be displayed in the
>>>>>>> list below the Manage Macros menu item and on clicking on the particular
>>>>>>> macro, it will be executed in the SQL Editor
>>>>>>>

---

From: Khushboo Vashi <[email-masked]>
Date: Tue, 1 Sep 2020 11:59:14 +0530

On Tue, Sep 1, 2020 at 11:54 AM Chethana Kumar <
[email-masked]> wrote:

> I like this design (Sample1)

---

From: Chethana Kumar <[email-masked]>
Date: Tue, 1 Sep 2020 12:06:23 +0530

On Tue, Sep 1, 2020 at 11:59 AM Khushboo Vashi <
[email-masked]> wrote:

>> I am sort of ok with Khushboo's design solution which re-uses the
>> existing UI element called sub-node control.
>>

Yes me too because the interaction pattern is as same as the "checkbox" one
that we have seen already.
It just inherits the interaction pattern of it.

But let see what others feel.

---
Chethana Kumar

>>>> Basically the key is going to be the non-editable field (unique key)
>>>> and the user can not change it. Users can only change name and SQL, so the
>>>> key is in first place.
>>>>

---

From: Dave Page <[email-masked]>
Date: Tue, 1 Sep 2020 10:22:02 +0100

On Tue, Sep 1, 2020 at 7:36 AM Chethana Kumar <
[email-masked]> wrote:

>>> At the same time, I wanted to increase the ease of use and less
>>> cluttered there.
> Yes me too because the interaction pattern is as same as the "checkbox"
> one that we have seen already.

I prefer Sample1. Sample2 makes more sense when you're doing something
"atomic" on a group of objects (e.g. dropping a bunch of tables at once).
Here it seems like you're not likely to ever do that; you'll most likely be
working on one macro at a  time.

It also requires fewer clicks.

>>>> - Can we have the dropdown menu as below? As you can see user can
>>>>>> select the "entered query from the query editor" then directly press "New
>>>>>> Macro" which saves the user time and energy too.  Please correct me if this
>>>>>> is not something logical working one.
>>>>>>
>>>>>>> On Thu, Aug 27, 2020 at 5:34 PM Dave Page <
>>>>>>> [email-masked]> wrote:
>>>>>>>