Subject: [pgAdmin][RM6081] Advanced table fields in ERD

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 11 Oct 2021 17:13:25 +0530

Hi Hackers,

Attached patch will port Backbone based dialogs in ERD to React based using
the schema view UI framework. This allows us to use the existing table UI,
remove repeated code and enable advanced fields. I have hidden fields from
the existing table UI for ERD.
Please note, this also fixes #6529.

Please review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin Hacker | Software Architect | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 11 Oct 2021 17:43:49 +0530

Thanks, the patch applied.

On Mon, Oct 11, 2021 at 5:14 PM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Hackers,
>
> Attached patch will port Backbone based dialogs in ERD to React based
> using the schema view UI framework. This allows us to use the existing
> table UI, remove repeated code and enable advanced fields. I have hidden
> fields from the existing table UI for ERD.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 12 Oct 2021 11:35:43 +0530

Hi,

Please review the attached patch to fix failing API test case.

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 12 Oct 2021 15:04:49 +0530

On Tue, Oct 12, 2021 at 11:36 AM Aditya Toshniwal <
[email-masked]> wrote:

> On Mon, Oct 11, 2021 at 5:44 PM Akshay Joshi <
> [email-masked]> wrote:
>