Subject: [pgAdmin][SonarQube] Reduce cognitive complexity

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 1 Sep 2020 15:34:02 +0530

Hi Hackers,

Attached patch reduces cognitive complexity as below:

web/.../server_groups/servers/pgagent/__init__.py - 23 to 15
web/pgadmin/utils/driver/psycopg2/__init__.py - 23 to 15, 17 to 15
web/setup.py 77 to 15

Please review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 2 Sep 2020 17:30:49 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*