Subject: [pgAdmin][SonarQube] Reduce cognitive complexity

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 22 Sep 2020 11:03:29 +0530

Hi Hackers,

Attached path will reduce the cognitive complexity as
below:web/pgadmin/misc/file_manager/__init__.py
40 to 15; 43 to 15

Please review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 22 Sep 2020 14:56:29 +0530

Hi Aditya

The patch fixes only 1 code smell and introduce 1 new. Please fix those and
resend the patch.

On Tue, Sep 22, 2020 at 11:04 AM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Hackers,
>
> Attached path will reduce the cognitive complexity as below:web/pgadmin/misc/file_manager/__init__.py
> 40 to 15; 43 to 15
>
> Please review.
>
>
> --
> Thanks,
> Aditya Toshniwal

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 22 Sep 2020 16:48:26 +0530

Hi,

Please find the updated patch.

On Tue, Sep 22, 2020 at 2:56 PM Akshay Joshi <[email-masked]>
wrote:

> Hi Aditya
>
> The patch fixes only 1 code smell and introduce 1 new. Please fix those
> and resend the patch.
>