Subject: [pgAdmin][SonarQube] Reduce cognitive complexity

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 8 Sep 2020 18:12:47 +0530

Attached patch reduces the cognitive complexity as below:
web/pgadmin/tools/sqleditor/utils/is_begin_required.py - 89 to 15
web/pgadmin/utils/driver/psycopg2/connection.py - 16 to 15
web/setup.py - 17 to 15

Please review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 9 Sep 2020 11:26:39 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*