Subject: [pgadmin4][Patch]: Feature #3388 Allow to set the connection timeout on the server properties dialog

From: Akshay Joshi <[email-masked]>
Date: Mon, 18 Jun 2018 16:48:16 +0530

Hi Hackers,

Attached is the patch for Feature #3388 Allow to set the connection timeout
on the server properties dialog. Please review it.

-- 
*Akshay Joshi*

*Sr. Software Architect *

*Phone: +91 20-3058-9517Mobile: +91 976-788-8246*

---

From: Dave Page <[email-masked]>
Date: Mon, 18 Jun 2018 18:09:04 +0100

Hi

On Mon, Jun 18, 2018 at 12:18 PM, Akshay Joshi <
[email-masked]> wrote:

> Hi Hackers,
>
> Attached is the patch for Feature #3388 Allow to set the connection
> timeout on the server properties dialog. Please review it.
>

I took a quick look at this and had some questions/comments:

- Doc updates seem to be missing.

- The timeout should be passed through to external utilities like
pg_dump/pg_restore.

- Can/should the timeout be extended to the SSH tunnels?

- Any refactoring opportunities in the code you're touching?

Thanks.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 19 Jun 2018 14:11:18 +0530

Hi

> - Doc updates seem to be missing.

    My bad, again I forgot to do that. Fixed in attached patch.

> - The timeout should be passed through to external utilities like

   I am not able to see any option to set the timeout for
pg_dump/pg_restore.

> - Can/should the timeout be extended to the SSH tunnels?

     No option to set the timeout, I have check the sshtunnel's
documentation <https://sshtunnel.readthedocs.io/en/latest/>.

> - Any refactoring opportunities in the code you're touching?

    Not seen any logic that can be refactored.

> Thanks.

   Apart from above, I have found one issue in *datamodel.js* when setting
the min value to 0 for input control, it didn't work.

-- 
*Akshay Joshi*

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 19 Jun 2018 16:48:06 +0530

Hi

On Tue, Jun 19, 2018 at 2:11 PM, Akshay Joshi <[email-masked]
> wrote:

>    I am not able to see any option to set the timeout for

      Fixed it by setting environment variable "PGCONNECT_TIMEOUT".
Attached is the new updated patch.

>    Apart from above, I have found one issue in *datamodel.js* when
> setting the min value to 0 for input control, it didn't work.
>
>>
>> --
>> Dave Page

-- 
*Akshay Joshi*

---

From: Dave Page <[email-masked]>
Date: Wed, 20 Jun 2018 00:59:02 +0100

Thanks, applied.

On Tue, Jun 19, 2018 at 12:18 PM, Akshay Joshi <
[email-masked]> wrote:

> Hi
>
> On Tue, Jun 19, 2018 at 2:11 PM, Akshay Joshi <