Subject: [pgAdmin][RM5181] Add support for parameters toast_tuple_target and parallel_workers of table

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 30 Mar 2020 19:47:13 +0530

Hi Hackers,

Attached is a patch to add support for parameters toast_tuple_target (PG
v11+) and parallel_workers(PG 9.6+) of table. Refer -
https://www.postgresql.org/docs/11/sql-createtable.html#SQL-CREATETABLE-STORAGE-PARAMETERS
.

Both the parameters are added in the advanced tab of table dialog.

The patch also fixes a related issue - RM5180, where autovacuum_enabled
parameter is added automatically in the RE-SQL when table has been created
with WITH parameter.

Please review.

-- 
Thanks and Regards,
Aditya Toshniwal
pgAdmin Hacker | Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 1 Apr 2020 14:51:32 +0530

Hi Aditya

API/RESQL test cases are failing for EPAS/PG 9.6 and maybe above. Please
fix and resend the patch.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 1 Apr 2020 15:35:21 +0530

Hi Akshay,

> fix and resend the patch.
The SQL is corrected for 9.6 versions. Others seems to be working fine.
Attached is the updated patch.
Please review.

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 1 Apr 2020 17:10:35 +0530

Hi Aditya

Tested on 9.6, test cases are fixed but wrong SQL generated for tables:
CREATE TABLE public.test
(
    col1 bigint
)
WITH (
    OIDS = FALSE,,
    parallel_workers = 56    autovacuum_enabled = TRUE,

Also parameter parallel_workers is not showing until we enabled the
autovacuum parameters.

Please fix and resend the patch.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 1 Apr 2020 17:37:30 +0530

Documentation and Screenshot need to be updated.

On Wed, Apr 1, 2020 at 5:10 PM Akshay Joshi <[email-masked]>
wrote:

>> On Wed, Apr 1, 2020 at 2:51 PM Akshay Joshi <
>> [email-masked]> wrote:
>>
>>> Hi Aditya
>>>
>>>> Attached is a patch to add support for parameters toast_tuple_target
>>>> (PG v11+) and parallel_workers(PG 9.6+) of table. Refer -

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 1 Apr 2020 18:05:12 +0530

Hi Hackers,

Attached is the updated patch. The issue was on PG9.6, fixed that.
Docs updated.

Please review.

On Wed, Apr 1, 2020 at 5:37 PM Akshay Joshi <[email-masked]>
wrote:

>>>> API/RESQL test cases are failing for EPAS/PG 9.6 and maybe above.
>>>>> The patch also fixes a related issue - RM5180,
>>>>> where autovacuum_enabled parameter is added automatically in the RE-SQL
>>>>> when table has been created with WITH parameter.
>>>>>
>>>>> Please review.
>>>>>
>>>>> --
>>>>> Thanks and Regards,
>>>>> Aditya Toshniwal

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 1 Apr 2020 18:21:38 +0530

Thanks, patch applied.

On Wed, Apr 1, 2020 at 6:05 PM Aditya Toshniwal <
[email-masked]> wrote:

>> On Wed, Apr 1, 2020 at 5:10 PM Akshay Joshi <

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*