Subject: [pgAdmin4][Patch]: RM #4362 trigger function create script

From: Akshay Joshi <[email-masked]>
Date: Wed, 19 Jun 2019 14:25:01 +0530

Hi Hackers,

Attached is the patch to fix RM #4362 trigger function create script.
Please review it.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Dave Page <[email-masked]>
Date: Wed, 19 Jun 2019 15:27:46 +0100

Hi

> Attached is the patch to fix RM #4362 trigger function create script.

While I can see how this works, I question why we have the string "SETOF"
in prorettypname anyway? That's a separate property, so it should be in a
separate variable. What if I have a type called "SETOFDavesStuff"
(unlikely, but it illustrates the point)?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 19 Jun 2019 20:47:01 +0530

Hi Dave

On Wed, 19 Jun, 2019, 19:57 Dave Page, <[email-masked]> wrote:

> Hi
>
> On Wed, Jun 19, 2019 at 9:55 AM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Hackers,
>>

    We have used pg_get_function_result(func_oid) to get the returns clause
for function and assign its value to prorettypename variable. I have
followed the same logic for trigger function and fixed it. Similar logic
has already been used for functions.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 20 Jun 2019 12:18:34 +0530

Hi Dave

On Wed, Jun 19, 2019 at 8:47 PM Akshay Joshi <[email-masked]>
wrote:

>     We have used pg_get_function_result(func_oid) to get the returns
> clause for function and assign its value to prorettypename variable. I have

    I have tested it with two different type "SETOF TypeTest" and
"SETOFType" for function, as trigger_function only have return type either
trigger or event_trigger. I haven't found any issue with the reverse
engineered sql and create script as well.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Dave Page <[email-masked]>
Date: Thu, 20 Jun 2019 13:19:44 +0100

Thanks, applied.

On Thu, Jun 20, 2019 at 7:48 AM Akshay Joshi <[email-masked]>
wrote:

> Hi Dave
>
> On Wed, Jun 19, 2019 at 8:47 PM Akshay Joshi <
>>> While I can see how this works, I question why we have the string
>>> "SETOF" in prorettypname anyway? That's a separate property, so it should
>>> be in a separate variable. What if I have a type called "SETOFDavesStuff"