Subject: [pgAdmin4][Patch] - RM 5270 - [EPAS] Synonym properties does not show OID.

From: Khushboo Vashi <[email-masked]>
Date: Tue, 7 Apr 2020 18:37:12 +0530

Hi,

Please find the attached patch to fix the RM # 5270 - [EPAS] Synonym
properties does not show OID.

As per the current implementation, we completely ignored OID and instead
considered the name as the unique field, now with this patch OID will be
used as an unique id and also will display OID in the properties tab.

Thanks,
Khushboo

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 8 Apr 2020 12:33:31 +0530

Hi Khushboo

Schema Diff test cases are failing with this patch. Please fix and resend
the patch.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Ashesh Vashi <[email-masked]>
Date: Wed, 8 Apr 2020 12:39:59 +0530

> used as an unique id and also will display OID in the properties tab.
Question is: When we rename a synonym, does it create a new OID, or keep
the same?

-- Ashesh

---

From: Khushboo Vashi <[email-masked]>
Date: Wed, 8 Apr 2020 12:47:45 +0530

On Wed, Apr 8, 2020 at 12:40 PM Ashesh Vashi <[email-masked]>
wrote:

> We can not rename a synonym, must drop it and recreate it.

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 8 Apr 2020 12:53:37 +0530

Hi Khushboo

View/MView test also failing with the commit of #5053. Please fix those as
well and send a combined patch.

On Wed, Apr 8, 2020 at 12:47 PM Khushboo Vashi <
[email-masked]> wrote:

>
>
> On Wed, Apr 8, 2020 at 12:40 PM Ashesh Vashi <
> [email-masked]> wrote:
>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: Khushboo Vashi <[email-masked]>
Date: Fri, 10 Apr 2020 10:41:34 +0530

Hi Akshay,

On Wed, Apr 8, 2020 at 12:33 PM Akshay Joshi <[email-masked]>
wrote:

> Can you please re-verify as I don't think schema diff test cases are
failing due to this patch.

Thanks,
Khushboo

---

From: Khushboo Vashi <[email-masked]>
Date: Fri, 10 Apr 2020 11:58:00 +0530

Hi,

Please find the attached updated patch.

Thanks,
Khushboo

On Fri, Apr 10, 2020 at 10:41 AM Khushboo Vashi <
[email-masked]> wrote:

> Hi Akshay,
>
> On Wed, Apr 8, 2020 at 12:33 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Khushboo
>>
>> Fixed.

Thanks,
Khushboo

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 10 Apr 2020 14:55:30 +0530

Thanks patch applied.

On Fri, Apr 10, 2020 at 11:58 AM Khushboo Vashi <
[email-masked]> wrote:

>>> Schema Diff test cases are failing with this patch. Please fix and
>>> resend the patch.
>>>
>>> Fixed.
>
> Thanks,
> Khushboo
>
>>>> As per the current implementation, we completely ignored OID and
>>>> instead considered the name as the unique field, now with this patch OID
>>>> will be used as an unique id and also will display OID in the properties
>>>> tab.
>>>>
>>>> Thanks,
>>>> Khushboo
>>>>
>>>>
>>>
>>> --
>>> *Thanks & Regards*
>>> *Akshay Joshi*
>>>
>>> *Sr. Software Architect*

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*