Subject: [pgAdmin][RM5815] Generate script is not working in new window

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 9 Sep 2020 15:18:27 +0530

Hi Hackers,

If schema diff is opened in a new tab and "Generate script" is clicked
(with query tool setting "open in new tab" set to true) then it shows a
forever spinner because of pop up blocks.

Attached patch will show an alert message in that case so that the user can
allow pop up and generate the script again.

Please review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 9 Sep 2020 20:13:13 +0530

Thanks, patch applied.

On Wed, Sep 9, 2020 at 3:19 PM Aditya Toshniwal <
[email-masked]> wrote:

> Attached patch will show an alert message in that case so that the user
> can allow pop up and generate the script again.
>
> Please review.
>
> --
> Thanks,
> Aditya Toshniwal

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*