Subject: [pgAdmin][RM3279] the Drop and Disconnect connection menupoints are too close for each others

From: Rahul Shirsat <[email-masked]>
Date: Tue, 5 Nov 2019 14:47:58 +0530

Hi Hackers,

Attached is the patch to move "Delete/Drop" menu option away from
"Disconnect Servers" for server node.

Additionally, I have renamed the "Delete/Drop" menu option to "Remove
Server" for server node against issue RM3859.

-- 
*Rahul Shirsat*
Software Engineer | EnterpriseDB Corporation | Pune.

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 5 Nov 2019 15:36:40 +0530

Hi Rahul

Following are the review comments:

   - Priority should be set to 5 instead of 997, as the 'Remove Server'
   menu goes very down with that priority. 'Remove Server' menu should be near
   to 'Connect Server' and 'Disconnect Server'. I have tested it with 5 and it
   looks fine. Refer the below screenshot

                                 [image: Screenshot 2019-11-05 at 3.27.22
PM.png]   

   - As we have renamed the menu from 'Drop Server' to 'Remove Server' we
   should also change the same for the below dialog when the user clicks on
   the menu:

                                 [image: Screenshot 2019-11-05 at 3.16.55
PM.png]

   - Please check the documentation as we renamed the menu, so we may need
   to change the docs.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 7 Nov 2019 13:12:58 +0530

Thanks, patch applied.

On Wed, Nov 6, 2019 at 6:17 PM Rahul Shirsat <[email-masked]>
wrote:

> Hi Akshay,
>
> Please find below comments and the attached patch for your reference.
>
> On Tue, Nov 5, 2019 at 3:36 PM Akshay Joshi <[email-masked]>
> wrote:
>
>> Hi Rahul
>>
>>    looks fine. Refer the below screenshot - *Fixed*
>>
>>                                  [image: Screenshot 2019-11-05 at
>> 3.27.22 PM.png]   
>>
>>    - As we have renamed the menu from 'Drop Server' to 'Remove Server'
>>    we should also change the same for the below dialog when the user clicks on
>>    the menu - *Fixed*
>>
>>                                  [image: Screenshot 2019-11-05 at
>> 3.16.55 PM.png]
>>
>>    - Please check the documentation as we renamed the menu, so we may
>>    need to change the docs - *Fixed*
>>
>>
>>
>>
>> On Tue, Nov 5, 2019 at 2:48 PM Rahul Shirsat <
>> [email-masked]> wrote:
>>
>>> Hi Hackers,
>>>
> Software Engineer | EnterpriseDB Corporation.
>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*