Subject: Fix a bug of schema diff when comparing triggers with different when clauses

From: "[email-masked]" <[email-masked]>
Date: Mon, 1 Mar 2021 00:58:54 +0000

Hi,

When I compare triggers with different when clauses, it shows the wrong diff DDL.

I tried to fix the bug , as the attached patch shows.

--

Thanks && regards

HuangJ

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 1 Mar 2021 13:21:10 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*