Subject: [pgAdmin[patch] Ignore flask-security-too irrelevant vulnerability

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 21 Oct 2021 10:47:34 +0530

Hi Hackers,

As per safety audit vulnerability report id #40493 for flask-security-too:
*This is considered a low severity due to the fact that if Werkzeug is used
(which is very common with Flask applications) as the WSGI layer, it by
default ALWAYS ensures that the Location header is absolute - thus making
this attack vector mute.*

Attached patch will ignore this ID for the audit.

-- 
Thanks,
Aditya Toshniwal
pgAdmin Hacker | Software Architect | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 21 Oct 2021 11:15:35 +0530

Thanks, the patch applied.

On Thu, Oct 21, 2021 at 10:48 AM Aditya Toshniwal <
[email-masked]> wrote:

> *This is considered a low severity due to the fact that if Werkzeug is
> used (which is very common with Flask applications) as the WSGI layer, it
> by default ALWAYS ensures that the Location header is absolute - thus
> making this attack vector mute.*
>

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*