Subject: [pgAdmin4][Patch] - RM #7179 - PostgreSQL deployment on EDB BigAnimal

From: Khushboo Vashi <[email-masked]>
Date: Mon, 11 Apr 2022 09:42:18 +0530

Hi,

Please find the attached patch for the implementation of the RM #7179
- PostgreSQL
deployment on EDB BigAnimal.

Thanks,
Khushboo

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 18 Apr 2022 12:46:57 +0530

Hi Khushboo

Following are the review comments:
*GUI:*

   - Facing error in the browser. Please check the below screenshot

   - Unable to test ahead because 'Regions' are not available to select in
   the dropdown. Even the code has been verified successfully

                  .        

*Code:*

   - Jasmine test cases are missing.
   - Documentation is missing.
   - Function comments are not present in the new files. Overall very less
   comments about the code. Add comments in rds.py and io.py
   - Access token gets printed at the backend, it should not or at
   least should be in the Debug log.
   - Move BASE_URL = 'https://portal.biganimal.com/api/v1' to constants.py
   and remove it from the multiple files.
   - Fixed SonarQube issues from the new files and from existing files if
   introduced with this patch or previous patch for AWS RDS.
   - Update line "help='Amazon AWS RDS PostgreSQL'" in BigAnimal.py.
   -

   sid = _create_server({
       'gid': data['db_details']['gid'],
       'name': data['instance_details']['cluster_name'],
       'db': 'edb_admin',
       'username': 'edb_admin',
       'port': 5432,
       'cloud_status': -1
   }).  Update Why db, username and port are hard coded?

   -

   In "misc/cloud/__init__.py" two function with same name "def
get_db_versions()"

   -

   Correct the string "edb_bibanimal_authentication" to
"edb_biganimal_authentication" in CloudWizard.jsx and 'VigAnimal
Volume Types" to "BigAnimal Volume Types".

On Thu, Apr 14, 2022 at 2:04 PM Khushboo Vashi <
[email-masked]> wrote:

> Hi,
>
> Please find the attached patch for the implementation of the RM #7179 - PostgreSQL

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Khushboo Vashi <[email-masked]>
Date: Mon, 18 Apr 2022 13:56:10 +0530

>    - Facing error in the browser. Please check the below screenshot
I have left some space above as per the comment given in the demo.

>
>    - Unable to test ahead because 'Regions' are not available to select
>    in the dropdown. Even the code has been verified successfully
>
>                   .        
>
This is working fine for me.

> Documentation is already written and attached with the patch.

>
>    - Function comments are not present in the new files. Overall very
>    less comments about the code. Add comments in rds.py and io.py
>    - Move BASE_URL = 'https://portal.biganimal.com/api/v1' to
>    constants.py and remove it from the multiple files.
>    In "misc/cloud/__init__.py" two function with same name "def get_db_versions()"
>
>    -
>
>    Correct the string "edb_bibanimal_authentication" to "edb_biganimal_authentication" in CloudWizard.jsx and 'VigAnimal Volume Types" to "BigAnimal Volume Types".
>
>
>

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 18 Apr 2022 14:55:00 +0530

On Mon, Apr 18, 2022 at 1:56 PM Khushboo Vashi <
[email-masked]> wrote:

>
>
> On Mon, Apr 18, 2022 at 12:47 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Khushboo
>>

    OK, Fix the error shown in the browser.

> This is working fine for me.

    We need to check this as not at all working for me. Am I missing
something?

>> Documentation is already written and attached with the patch.

    OK. After Aditya's commit patch needs to be rebased, fixed other review
comments, and send again with test cases.

>>    - Fixed SonarQube issues from the new files and from existing files
>>    if introduced with this patch or previous patch for AWS RDS.

---

From: Khushboo Vashi <[email-masked]>
Date: Mon, 25 Apr 2022 17:54:14 +0530

Hi,

Please find the attached updated patch with the suggested fixes.

Thanks,
Khushboo

On Mon, Apr 18, 2022 at 2:55 PM Akshay Joshi <[email-masked]>
wrote:

>     OK. After Aditya's commit patch needs to be rebased, fixed other
> review comments, and send again with test cases.
>
>>

---

From: Khushboo Vashi <[email-masked]>
Date: Tue, 26 Apr 2022 15:35:16 +0530

Hi,

Please find the attached updated patch.

Thanks,
Khushboo

On Mon, Apr 25, 2022 at 5:54 PM Khushboo Vashi <
[email-masked]> wrote:

> On Mon, Apr 18, 2022 at 2:55 PM Akshay Joshi <
>>>>    - Unable to test ahead because 'Regions' are not available to
>>>>    select in the dropdown. Even the code has been verified successfully
>>>>
>>>>                   .        
>>>>
>>>>> - PostgreSQL deployment on EDB BigAnimal.
>>>>>
>>>>> Thanks,
>>>>> Khushboo
>>>>>
>>>>>
>>>>
>>>> --
>>>> *Thanks & Regards*
>>>> *Akshay Joshi*

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 26 Apr 2022 16:42:24 +0530

Thanks, the patch applied.

On Tue, Apr 26, 2022 at 3:35 PM Khushboo Vashi <
[email-masked]> wrote:

>>>>>    - Fixed SonarQube issues from the new files and from existing
>>>>>    files if introduced with this patch or previous patch for AWS RDS.