Subject: [pgAdmin][RM4320] PgAdmin 4 fails to accept ssh password

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 5 Jun 2019 10:43:36 +0530

Hi Hackers,

Attached is the patch to fix a regression of Master Password #4184 where
SSH tunnel connection using password is failing.

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 5 Jun 2019 12:11:05 +0530

Thanks patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 25 Jun 2019 11:29:48 +0530

Hi Hackers,

Based on the latest comments on the RM,
https://redmine.postgresql.org/issues/4320#change-16998 - Replaced
server_manager.py on my Win 10 system - could login and run queries, etc -
but eventually got "create_ssh_tunnel() missing 1 required positional
argument: 'tunnel_password'",attached is the patch to fix the issue.

Kindly review and consider this for the upcoming release.

---

From: Dave Page <[email-masked]>
Date: Tue, 25 Jun 2019 07:06:24 -0400

Thanks, committed.

On Tue, Jun 25, 2019 at 2:00 AM Aditya Toshniwal <
[email-masked]> wrote:

> On Wed, Jun 5, 2019 at 12:11 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Thanks patch applied.
>>

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company