Subject: [pgAdmin][RM4506] "can't execute an empty query" message displayed if user remove fill factor of any existing table

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 9 Dec 2019 15:32:58 +0530

Hi Hackers,

Attached is the patch to fix an issue where just clicking on an
empty textbox like fill factor in tables dialog considers it a change and
so the save button is enabled.
The fix is common will apply at other places also.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 9 Dec 2019 16:30:30 +0530

Hi Aditya

The issue has not been resolved. Remove fill factor it won't generate MSQL.
Please verify and fix it.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 10 Dec 2019 12:56:46 +0530

Hi Hackers,

Attached is the updated patch. The modified SQL missed the reset clause for
FILLFACTOR. That's added now.
I've changed the int/numeric field validation to disallow spaces in the
form field. Currently,  fill factor allows spaces and fails while saving as
"invalid value".
Also, added min and max for fill factor in Mview dialog.

All the test cases are passing. Kindly review.

On Mon, Dec 9, 2019 at 4:30 PM Akshay Joshi <[email-masked]>
wrote:

> Hi Aditya
>
> The issue has not been resolved. Remove fill factor it won't generate
> MSQL. Please verify and fix it.
>

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 11 Dec 2019 14:53:57 +0530

Thanks, patch applied.

On Tue, Dec 10, 2019 at 12:57 PM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Hackers,
>
> Attached is the updated patch. The modified SQL missed the reset clause
> for FILLFACTOR. That's added now.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*