Subject: [pgAdmin][RM-5404]: Show the login roles that are members of a group role be shown when examining a group role.

From: Nikhil Mohite <[email-masked]>
Date: Wed, 10 Mar 2021 17:31:36 +0530

Hi Hackers,

Please find the attached patch for RM-5404
<https://redmine.postgresql.org/issues/5404>: Show the login roles that are
members of a group role be shown when examining a group role.
Updated the existing "Role" label to "Member of" and added a new option
"Members" to show all the roles that are members of the current Role/Group.
Users can add or remove the roles from the list similar to the "Members of"
option.

Also added 2 UI fixes:
1. "Member of" (Roles in earlier implementation) and "Members" fields
(Membership section) should be read-only in the properties panel.
2. If the select2 controller is set to read-only its background color is
not getting set as per the theme color. (earlier it is set to '#eee' for
all themes.)

-- 
*Thanks & Regards,*
*Nikhil Mohite*
*Software Engineer.*
*EDB Postgres* <https://www.enterprisedb.com/>
*Mob.No: +91-7798364578.*

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 12 Mar 2021 13:34:33 +0530

Thanks, patch applied.

On Wed, Mar 10, 2021 at 5:31 PM Nikhil Mohite <
[email-masked]> wrote:

> <https://redmine.postgresql.org/issues/5404>: Show the login roles that
> are members of a group role be shown when examining a group role.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Nikhil Mohite <[email-masked]>
Date: Fri, 19 Mar 2021 15:00:33 +0530

Hi Akshay/ Team,

Please find the updated patch.
Details:
1. Hide the close tag icon on the role property tab (for 'Member of' and
'Member' field). - resolved

Regards,
Nikhil Mohite

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 19 Mar 2021 15:56:03 +0530

Thanks, patch applied.

On Fri, Mar 19, 2021 at 3:00 PM Nikhil Mohite <
[email-masked]> wrote:

> On Fri, Mar 12, 2021 at 1:34 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Thanks, patch applied.
>>