Subject: [pgAdmin][RM4772][Accessibility] Provide aria-label to an invisible label where a visible label cannot be used

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 3 Dec 2019 11:38:57 +0530

Hi Hackers,

Attached is the patch to add label and aria-label wherever applicable. The
patch also fixes few other accessibility related errors raised by "WAVE"
extension of Chrome.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Sr. Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 3 Dec 2019 12:48:38 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 4 Dec 2019 15:00:15 +0530

Hi Hackers,

Attached is the patch to fix the feature tests which were failing after the
commit. The reason being, the span elements which was used to show
properties tab data is changed to input now as per accessibility
requirements. Also, there is no way now to check XSS of input because the
input tags returns the original value on extracting the value attribute and
not the escaped value. Previously, the value was HTML element under the
span tag.
Not to worry, input is escaped and is XSS free, handled in underscore
templates.

On Tue, Dec 3, 2019 at 12:48 PM Akshay Joshi <[email-masked]>
wrote:

>> Attached is the patch to add label and aria-label wherever applicable.
>> The patch also fixes few other accessibility related errors raised by
>> "WAVE" extension of Chrome.
>>
>> Kindly review.
>>
>> --
>> Thanks and Regards,
>> Aditya Toshniwal

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 4 Dec 2019 18:19:40 +0530

Thanks, patch applied.

On Wed, Dec 4, 2019 at 3:00 PM Aditya Toshniwal <
[email-masked]> wrote:

> Hi Hackers,
>
> Attached is the patch to fix the feature tests which were failing after
> the commit. The reason being, the span elements which was used to show
> On Tue, Dec 3, 2019 at 12:48 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Thanks, patch applied.
>>

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*