Subject: Remove hacky way to open/close the dropdown-submenu

From: Ashesh Vashi <[email-masked]>
Date: Thu, 17 Jan 2019 19:39:56 +0530

Hi Aditya/Khushboo,

I can see a hacky way to open/close the dropdown-submenu in the menu.js
file.
I've followed a more general way to open/close any submenu in the dropdown
list, instead of just 'Objects' menu.

Can you please review it, and let me know your thoughts?
Let me know if you have any other better approach.

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>

---

From: Ashesh Vashi <[email-masked]>
Date: Tue, 22 Jan 2019 10:07:37 +0530

Any update?

--

Thanks & Regards,

Ashesh Vashi

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 22 Jan 2019 10:25:21 +0530

Hi Ashesh,

I am getting a syntax error on bundle.
After fixing that,  please look into this scenario:
Using keyboard shortcuts open object menu, for eg on table node. Go to any
submenu using keyboard and go to any submenu and press enter.
Now open object menu again using keyboard shortcut, the submenu remains
open. It should be closed.

Everything looks fine to me except the above.

On Tue, Jan 22, 2019 at 10:07 AM Ashesh Vashi <[email-masked]>
wrote:

> On Thu, Jan 17, 2019 at 7:39 PM Ashesh Vashi <
> [email-masked]> wrote:
>
>> Hi Aditya/Khushboo,
>>
>> I've followed a more general way to open/close any submenu in the
>> dropdown list, instead of just 'Objects' menu.
>>

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB Software Solutions | Pune
"Don't Complain about Heat, Plant a tree"

---

From: Ashesh Vashi <[email-masked]>
Date: Thu, 31 Jan 2019 11:32:10 +0530

Hi Aditya,

> open. It should be closed.
Please find the updated patch with all comments fixed.
Now - whenever the callback for the menu is called (menu toggling), it will
close the existing submenu(s) too.

Please review it, and let me know.

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com/>

*http://www.linkedin.com/in/asheshvashi
<http://www.linkedin.com/in/asheshvashi>*

> On Tue, Jan 22, 2019 at 10:07 AM Ashesh Vashi <

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 31 Jan 2019 14:38:04 +0530

Hi Ashesh,

All works good, except one small change. Submenus should be closed if I
press Esc and then reopen the menu.

On Thu, Jan 31, 2019 at 11:32 AM Ashesh Vashi <[email-masked]>
wrote:

>> Using keyboard shortcuts open object menu, for eg on table node. Go to
>> any submenu using keyboard and go to any submenu and press enter.
> Now - whenever the callback for the menu is called (menu toggling), it
> will close the existing submenu(s) too.
>

---

From: Ashesh Vashi <[email-masked]>
Date: Thu, 31 Jan 2019 15:34:42 +0530

> press Esc and then reopen the menu.
Please find the updated patch to resolve the review comments.

-- Thanks, Ashesh

>
> On Thu, Jan 31, 2019 at 11:32 AM Ashesh Vashi <
>>>>> I can see a hacky way to open/close the dropdown-submenu in the
>>>>> menu.js file.

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 31 Jan 2019 16:04:56 +0530

Hi Ashesh,

The patch looks good to me.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 31 Jan 2019 17:51:21 +0530

Thanks patch applied.

On Thu, Jan 31, 2019 at 4:05 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Thu, Jan 31, 2019 at 3:34 PM Ashesh Vashi <
>>>>> Now open object menu again using keyboard shortcut, the submenu
>>>>> remains open. It should be closed.
>>>>>

-- 
*Akshay Joshi*

*Sr. Software Architect *

*Phone: +91 20-3058-9517Mobile: +91 976-788-8246*