Subject: [pgAdmin][patch] Partition node related fixes

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 6 Oct 2021 12:24:52 +0530

Hi Hackers,

Please review the attached patch which fixes:
1. Unable to create trigger for partition table. Fixes #6867.
2. Unable to create index, RLS policy, rules, triggers for partition. Fixes
#6868.

-- 
Thanks,
Aditya Toshniwal
pgAdmin Hacker | Software Architect | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 6 Oct 2021 14:54:37 +0530

Thanks, the patch applied.

On Wed, Oct 6, 2021 at 12:25 PM Aditya Toshniwal <
[email-masked]> wrote:

> 2. Unable to create index, RLS policy, rules, triggers for partition.
> Fixes #6868.
>
> --
> Thanks,
> Aditya Toshniwal

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 6 Oct 2021 16:37:20 +0530

Hi Hackers,

The nodes index, RLS policy, rules, triggers are failing to save for
partitions. Please review the attached patch to fix the issue.

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 6 Oct 2021 17:00:29 +0530

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 6 Oct 2021 17:32:10 +0530

Hi Hackers,

Following the chain, attached patch fixes indexes not loading in Primary
constraint and Unique const dialog for partition.

On Wed, Oct 6, 2021 at 5:00 PM Akshay Joshi <[email-masked]>
wrote:

>> On Wed, Oct 6, 2021 at 2:54 PM Akshay Joshi <
>> [email-masked]> wrote:
>>

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 6 Oct 2021 17:51:32 +0530