Subject: RE-SQL tests patch for packages node

From: navnath gadakh <[email-masked]>
Date: Wed, 10 Jul 2019 20:24:57 +0530

Hi Dave,

    I have attached the patch for RE-SQL test cases for *Packages* node.

Thanks!

-- 
*Regards,*
*Navnath Gadakh*

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 11 Jul 2019 12:37:16 +0530

Hi Navnath

I have tested the patch and it is not working for EPAS 9.4, 9.5 and 9.6.
Attached is the modified patch which fix the issue.
Please work on child node (functions, procedure and variables) of Packages
on top of modified patch.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Dave Page <[email-masked]>
Date: Thu, 11 Jul 2019 09:23:29 +0100

Thanks, applied.

-- 
Dave Page
VP, Chief Architect, Tools & Installers
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

---

From: navnath gadakh <[email-masked]>
Date: Fri, 12 Jul 2019 15:53:38 +0530

Hi Dave,

     Please find the modified patch for packages as test cases were failing
on some servers.
Thanks!

On Thu, Jul 11, 2019 at 1:53 PM Dave Page <[email-masked]>
wrote:

> Thanks, applied.
>
> On Thu, Jul 11, 2019 at 8:07 AM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Navnath
>>
>> Please work on child node (functions, procedure and variables) of
>> Packages on top of modified patch.
>>

-- 
*Regards,*
*Navnath Gadakh*

---

From: Dave Page <[email-masked]>
Date: Fri, 12 Jul 2019 11:32:39 +0100

Thanks, applied.

On Fri, Jul 12, 2019 at 11:24 AM navnath gadakh <
[email-masked]> wrote:

> Hi Dave,
>
>      Please find the modified patch for packages as test cases were
> failing on some servers.
> Thanks!
>
>

---

From: navnath gadakh <[email-masked]>
Date: Mon, 2 Sep 2019 17:02:56 +0530

Hi Dave,
         Please find the patch for M-SQL test cases for *Packages* module.

Thanks!

On Fri, Jul 12, 2019 at 4:02 PM Dave Page <[email-masked]>
wrote:

>>>> I have tested the patch and it is not working for EPAS 9.4, 9.5 and
>>>> 9.6. Attached is the modified patch which fix the issue.

-- 
*Regards,*
*Navnath Gadakh*

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 2 Sep 2019 17:43:21 +0530

Hi Navnath

Following are the review comments:

   - GRANT statement is not visible in RE-SQL for create and alter both.
   (May be bug in Packages please fix that too)
   - Delete packages is missing in json file.
   - Add test cases to revoke privileges(delete all the privileges). Check
   Languages node for reference.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: navnath gadakh <[email-masked]>
Date: Tue, 3 Sep 2019 13:36:15 +0530

Hi,

Please find the modified patch.

On Mon, Sep 2, 2019 at 5:43 PM Akshay Joshi <[email-masked]>
wrote:

> Done.

> Done.

>
>    - Add test cases to revoke privileges(delete all the privileges).
>    Check Languages node for reference.
>
> Done.

-- 
*Regards,*
*Navnath Gadakh*

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 3 Sep 2019 17:06:58 +0530

Hi Navnath

You forgot to add "create_package_with_all_options_msql.sql" and
"alter_package_headers_and_comment_msql.sql" file in your patch. Please
send the updated patch.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*

---

From: navnath gadakh <[email-masked]>
Date: Tue, 3 Sep 2019 17:16:26 +0530

Please check now.

On Tue, Sep 3, 2019 at 5:07 PM Akshay Joshi <[email-masked]>
wrote:

>> On Mon, Sep 2, 2019 at 5:43 PM Akshay Joshi <
>>>    - GRANT statement is not visible in RE-SQL for create and alter
>>>    both. (May be bug in Packages please fix that too)
>>>
>>> Done.
>>
>>>

-- 
*Regards,*
*Navnath Gadakh*

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 3 Sep 2019 17:35:26 +0530

Thanks patch applied.

On Tue, Sep 3, 2019 at 5:17 PM navnath gadakh <
[email-masked]> wrote:

>>>>>>> On Thu, Jul 11, 2019 at 1:53 PM Dave Page <
>>>>>>> [email-masked]> wrote:
>>>>>>>
>>>>>>>> Thanks, applied.
>>>>>>>>
>>>>>>>>> I have tested the patch and it is not working for EPAS 9.4, 9.5
>>>>>>>>> and 9.6. Attached is the modified patch which fix the issue.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*