Subject: [pgAdmin][RM5571] Expression in exclusion constraint is misinterpreted and quoted as column name by mistake

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 23 Dec 2020 18:10:08 +0530

Hi Hackers,

Attached is the patch to add support for expressions in exclusion
constraints. This also fixes the SQL generated for existing expression
based constraints also.
Docs updated and test cases enhanced.

Please review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 24 Dec 2020 13:14:49 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Thu, 24 Dec 2020 13:46:16 +0530

Hi,

Attached patch fixes the failing RESQL test cases.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 24 Dec 2020 15:02:11 +0530

Thanks, patch applied.

On Thu, Dec 24, 2020 at 1:46 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Thu, Dec 24, 2020 at 1:15 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Thanks, patch applied.
>>

---

From: Aditya Toshniwal <[email-masked]>
Date: Fri, 1 Jan 2021 12:35:22 +0530

Hi Hackers,

The changes in CREATE TABLE sql were missed. Attached patch adds the
changes.

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 4 Jan 2021 15:25:50 +0530

Thanks, patch applied.

On Fri, Jan 1, 2021 at 12:35 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Thu, Dec 24, 2020 at 3:02 PM Akshay Joshi <