Subject: SonarQube Fixes #5 Roles & Functions

From: Rahul Shirsat <[email-masked]>
Date: Wed, 17 Mar 2021 16:49:57 +0530

Hi Hackers,

Please find the patch which resolves below sonar qube issues:

For Roles:
Refactor this function to reduce its Cognitive Complexity from 21 to the 15
allowed
Refactor this function to reduce its Cognitive Complexity from 16 to the 15
allowed

For Functions:
Refactor this function to reduce its Cognitive Complexity from 17 to the 15
allowed

-- 
*Rahul Shirsat*
Senior Software Engineer | EnterpriseDB Corporation.

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 19 Mar 2021 11:56:58 +0530

Thanks, patch applied.

On Wed, Mar 17, 2021 at 4:50 PM Rahul Shirsat <
[email-masked]> wrote:

> Refactor this function to reduce its Cognitive Complexity from 21 to the
> 15 allowed
> Refactor this function to reduce its Cognitive Complexity from 16 to the
> 15 allowed
>
> For Functions:
> Refactor this function to reduce its Cognitive Complexity from 17 to the
> 15 allowed
>
> --
> *Rahul Shirsat*

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*