Subject: [pgAdmin4][Patch]: RM #3397 Add support for JIT stats in EXPLAIN output in PG11

From: Akshay Joshi <[email-masked]>
Date: Fri, 29 Jun 2018 14:25:58 +0530

Hi Hackers,

Attached is the patch to fix the RM #3397 Add support for JIT stats in
EXPLAIN output in PG11. Please review it.

-- 
*Akshay Joshi*

*Sr. Software Architect *

*Phone: +91 20-3058-9517Mobile: +91 976-788-8246*

---

From: Dave Page <[email-masked]>
Date: Fri, 29 Jun 2018 14:26:36 +0100

Hi

On Fri, Jun 29, 2018 at 9:55 AM, Akshay Joshi <[email-masked]
> wrote:

> EXPLAIN output in PG11. Please review it.

A couple of immediate thoughts:

- When the canvas is first rendered, there's a vertical scrollbar now. As
soon as I mouseover the new icon, it vanishes and the icon jumps to the
right.

- The icon seems lighter than the other controls on the left.

- The icon isn't disabled when there is no info to show.

Thanks.

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 29 Jun 2018 19:42:56 +0530

Hi Dave

On Fri, Jun 29, 2018 at 6:56 PM, Dave Page <[email-masked]> wrote:

> Hi
>
> On Fri, Jun 29, 2018 at 9:55 AM, Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Hackers,
>>

     Will look into it. Vertical scrollbar comes even if you remove my
patch and try to hover any image.

> - The icon seems lighter than the other controls on the left.

     Same css has been applied, only difference is button is disabled.

> - The icon isn't disabled when there is no info to show.

     Button is always disabled, I have just change the opacity.

-- 
*Akshay Joshi*

---

From: Dave Page <[email-masked]>
Date: Fri, 29 Jun 2018 15:15:59 +0100

On Fri, Jun 29, 2018 at 3:12 PM, Akshay Joshi <[email-masked]

>      Button is always disabled, I have just change the opacity.
Maybe - but I can still click it and it reacts as if it's active. It may be
lighter to indicate that it's disabled, but its not behaving as such.

---

From: Akshay Joshi <[email-masked]>
Date: Sat, 30 Jun 2018 13:45:36 +0530

Hi Dave

On Fri, Jun 29, 2018 at 7:45 PM, Dave Page <[email-masked]> wrote:

>
>
> On Fri, Jun 29, 2018 at 3:12 PM, Akshay Joshi <
>>> - When the canvas is first rendered, there's a vertical scrollbar now.
>>> As soon as I mouseover the new icon, it vanishes and the icon jumps to the
>>> right.
>>>
>>
> Maybe - but I can still click it and it reacts as if it's active. It may
> be lighter to indicate that it's disabled, but its not behaving as such.
>

    Attached is the modified patch. Please review it.

-- 
*Akshay Joshi*

---

From: Dave Page <[email-masked]>
Date: Mon, 2 Jul 2018 11:40:17 +0100

Hi

On Sat, Jun 30, 2018 at 9:15 AM, Akshay Joshi <[email-masked]

>>>>> Attached is the patch to fix the RM #3397 Add support for JIT stats
>>>>> in EXPLAIN output in PG11. Please review it.
>>>>>
>>>>

The button still changes foreground colour on mouseover when disabled.  I
think it needs to be completely non-reactive when disabled. It should also
be a noticably lighter shade when disabled; right now it seems to be darker
than the other buttons (see attached).

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 3 Jul 2018 12:35:25 +0530

Hi Dave,

On Mon, Jul 2, 2018 at 4:10 PM, Dave Page <[email-masked]> wrote:

> Hi
>
> On Sat, Jun 30, 2018 at 9:15 AM, Akshay Joshi <

-- 
*Akshay Joshi*

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 3 Jul 2018 18:40:16 +0530

Hi Dave,

Please ignore the previous patch, I have made some more changes related to
background colour on enabled/disabled state.
Attached is the modified patch. Please review it.

On Tue, Jul 3, 2018 at 12:35 PM, Akshay Joshi <[email-masked]

>>>>>> - When the canvas is first rendered, there's a vertical scrollbar
>>>>>> now. As soon as I mouseover the new icon, it vanishes and the icon jumps to
>>>>>> the right.
>>>>>>
>>>>>
>>>> Maybe - but I can still click it and it reacts as if it's active. It
>>>> may be lighter to indicate that it's disabled, but its not behaving as
>>>> such.
>>>>
>>>

-- 
*Akshay Joshi*

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 5 Jul 2018 15:51:18 +0530

Hi Dave

As per discussion attached is the modified patch with following review
comments has been fixed :

   - Hide statistics button if not applicable(no statistics to show).
   - Extract 'StatisticsModel' into a separate file and added jasmine test
   for this.

On Tue, Jul 3, 2018 at 6:40 PM, Akshay Joshi <[email-masked]>
wrote:

> On Tue, Jul 3, 2018 at 12:35 PM, Akshay Joshi <
>>>>>>>> Attached is the patch to fix the RM #3397 Add support for JIT
>>>>>>>> stats in EXPLAIN output in PG11. Please review it.
>>>>>>>>
>>>>>>>
>>>>>>      Will look into it. Vertical scrollbar comes even if you remove
>>>>>> my patch and try to hover any image.
>>>>>>
>>>>>>>
>>> The button still changes foreground colour on mouseover when disabled.
>>> I think it needs to be completely non-reactive when disabled. It should
>>> also be a noticably lighter shade when disabled; right now it seems to be
>>> darker than the other buttons (see attached).
>>>
>>

-- 
*Akshay Joshi*

---

From: Dave Page <[email-masked]>
Date: Thu, 5 Jul 2018 14:47:08 +0100

Hi

Looks good to me - the only remaining issue is that the button still isn't
the same colours as the zoom ones. I haven't found all the differences, but
there seems to be an 'opacity: 0.5" on the stats area, and the disabled
attribute is still being set.

On Thu, Jul 5, 2018 at 11:21 AM, Akshay Joshi <[email-masked]

>    - Extract 'StatisticsModel' into a separate file and added jasmine
>    test for this.
>
>
>
>
> On Tue, Jul 3, 2018 at 6:40 PM, Akshay Joshi <
>> Please ignore the previous patch, I have made some more changes related
>> to background colour on enabled/disabled state.

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 6 Jul 2018 11:14:25 +0530

Hi

> attribute is still being set.

    I have set the disabled attribute, so that the button shouldn't be
clickable and because of that there is difference in colour. 'opacity: 0.5'
is also there for zoom area. I have fixed the issue by removing disabled
attribute and add '

*pointer-events: none*' for the statistics button. Attached is the patch
please review it.

>
> On Thu, Jul 5, 2018 at 11:21 AM, Akshay Joshi <
>>>>> The button still changes foreground colour on mouseover when
>>>>> disabled.  I think it needs to be completely non-reactive when disabled. It
>>>>> should also be a noticably lighter shade when disabled; right now it seems
>>>>> to be darker than the other buttons (see attached).
>>>>>
>>>>

-- 
*Akshay Joshi*

---

From: Dave Page <[email-masked]>
Date: Fri, 6 Jul 2018 13:14:42 +0100

Thanks, patch applied!

On Fri, Jul 6, 2018 at 6:44 AM, Akshay Joshi <[email-masked]>
wrote:

>> Looks good to me - the only remaining issue is that the button still
>> isn't the same colours as the zoom ones. I haven't found all the
>> differences, but there seems to be an 'opacity: 0.5" on the stats area, and
>> the disabled attribute is still being set.
>>
>
> clickable and because of that there is difference in colour. 'opacity:
> 0.5' is also there for zoom area. I have fixed the issue by removing
> disabled attribute and add '
>
>>>>>>>>>      Will look into it. Vertical scrollbar comes even if you
>>>>>>>>> remove my patch and try to hover any image.
>>>>>>>>>
>>>>>>>>>>
>>>>>>>> Maybe - but I can still click it and it reacts as if it's active.
>>>>>>>> It may be lighter to indicate that it's disabled, but its not behaving as
>>>>>>>> such.
>>>>>>>>
>>>>>>>