Subject: [pgAdmin4[RM#3935] Grant wizard fails to list down functions

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 28 Jan 2019 12:01:12 +0530

Hi,

PFA patch to fix the issue where EPAS DB instance running with
*no-redwood-compat* mode fails to list down functions objects in grant
wizard due to 'char' -> 'int' type cast error.

--
Regards,
Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 28 Jan 2019 12:48:15 +0530

Thanks patch applied.

-- 
*Akshay Joshi*

*Sr. Software Architect *

*Phone: +91 20-3058-9517Mobile: +91 976-788-8246*

---

From: Murtuza Zabuawala <[email-masked]>
Date: Mon, 28 Jan 2019 14:49:00 +0530

Hi,

PFA minor patch, To display an error on UI when there is a backend error
for the grant wizard request.
Please review.

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 28 Jan 2019 16:38:22 +0530

Hi Murtuza

Here are my review comments:

   - Exact error should be logged in the log file and on GUI we should show
   message like "Unable to fetch <function/table> object".
   - Message should be shown in the status bar.
   - If there is an error to fetch one kind of object, we should show other
   objects.

On Mon, Jan 28, 2019 at 2:49 PM Murtuza Zabuawala <
[email-masked]> wrote:

> On Mon, Jan 28, 2019 at 12:48 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Thanks patch applied.
>>

-- 
*Akshay Joshi*

---

From: Murtuza Zabuawala <[email-masked]>
Date: Wed, 30 Jan 2019 15:10:17 +0530

Hi,

On Mon, Jan 28, 2019 at 4:38 PM Akshay Joshi <[email-masked]>
wrote:

>    - Exact error should be logged in the log file and on GUI we should
>    show message like "Unable to fetch <function/table> object".
>
> Fixed

> Fixed

>
>    - If there is an error to fetch one kind of object, we should show
>    other objects.
>
> Fixed.

Please find the updated patch.

Regards,
Murtuza

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 30 Jan 2019 16:40:10 +0530

Thanks patch applied.

On Wed, Jan 30, 2019 at 3:10 PM Murtuza Zabuawala <
[email-masked]> wrote:

> Hi,
>
> On Mon, Jan 28, 2019 at 4:38 PM Akshay Joshi <
>>>>> *no-redwood-compat* mode fails to list down functions objects in
>>>>> grant wizard due to 'char' -> 'int' type cast error.
>>>>>
>>>>>
>>>>> --
>>>>> Regards,
>>>>> Murtuza Zabuawala

-- 
*Akshay Joshi*