Subject: [pgAdmin] RM6098 Manually deleting from table view hangs

From: Rahul Shirsat <[email-masked]>
Date: Mon, 18 Jan 2021 20:21:04 +0530

Hi Hackers,

Please find the attached patch which resolves the issue of deleting records
when the user tries to delete multiple records step by step.

-- 
*Rahul Shirsat*
Senior Software Engineer | EnterpriseDB Corporation.

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 19 Jan 2021 13:40:59 +0530

Hi Nikhil

Can you please review it.

On Mon, Jan 18, 2021 at 8:21 PM Rahul Shirsat <
[email-masked]> wrote:

> Hi Hackers,
>
> Please find the attached patch which resolves the issue of deleting
> records when the user tries to delete multiple records step by step.
>
> --
> *Rahul Shirsat*

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Nikhil Mohite <[email-masked]>
Date: Tue, 19 Jan 2021 15:30:32 +0530

Hi Rahul,

While reviewing the patch, found one observation with deleted records.
1. Selected multiple records and click on delete records.
2. Now unselect or unmark any record. (click on index column cell to
unselect the row)
3. Click on the Save data changes button.
4. All selected records get deleted but the unselected records remain in
the grid.
5.  After re-executing the filter query that record gets removed from the
grid.

Regards,
Nikhil Mohite.

---

From: Rahul Shirsat <[email-masked]>
Date: Tue, 19 Jan 2021 20:52:55 +0530

Fixed the above observation. Removed unnecessary code for calling slickgrid
delete API.

On Tue, Jan 19, 2021 at 3:30 PM Nikhil Mohite <
[email-masked]> wrote:

> On Tue, Jan 19, 2021 at 1:41 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Nikhil
>>

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 20 Jan 2021 12:40:07 +0530

Thanks, patch applied.

On Tue, Jan 19, 2021 at 8:53 PM Rahul Shirsat <
[email-masked]> wrote:

> Fixed the above observation. Removed unnecessary code for calling
> slickgrid delete API.
>