Subject: [Patch][pgAdmin] RM4203 Rename Database by another user

From: Rahul Shirsat <[email-masked]>
Date: Wed, 26 May 2021 14:07:10 +0530

Hi Hackers,

Please find the attached patch which resolves the issue of renaming the
database by another user.

A minor issue of navigation button alignment is also fixed in this patch.

-- 
*Rahul Shirsat*
Senior Software Engineer | EnterpriseDB Corporation.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 27 May 2021 12:19:31 +0530

Hi Rahul

Following are the review comments:

   - Why you have changed the order of the toolbar button on the browser
   tree? It should not.
   - *sqleditor.js (check_db_name_change function)*
   - var declaration should be comma-separated instead of writing var,
      again and again.
      - Add proper comments.
      - Remove dots from the string "Database moved/renamed.."
      - "Please note that the database you are working on has been moved or
      renamed to ${data.actual_db_name}. Refresh databases in browser panel or
      click OK to continue.." should be changed to "Current database has been
      moved or renamed to ${data.actual_db_name}. Click on the OK button to
      refresh the database name."

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Rahul Shirsat <[email-masked]>
Date: Sun, 30 May 2021 00:02:27 +0530

Hi Akshay,

On Thu, May 27, 2021 at 12:19 PM Akshay Joshi <[email-masked]>
wrote:

>                Changes were related to the wcDocker issue showing reverse
order buttons, so had to change in the pgAdmin app to reflect it correctly.

>                           Done.

>
>    - Add proper comments.
>
>                           This too is taken care of.

>                           Done.

>                           Done.
                           Also have done some code refactoring.

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 1 Jun 2021 20:50:06 +0530

Thanks, the patch applied.

On Sun, May 30, 2021 at 12:03 AM Rahul Shirsat <
[email-masked]> wrote:

> Hi Akshay,
>
> On Thu, May 27, 2021 at 12:19 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Rahul
>>

---

From: Rahul Shirsat <[email-masked]>
Date: Mon, 7 Jun 2021 17:08:14 +0530

Hi Akshay,

Please find the updated patch below for your reference. I have added an
extra check for verifying the database rename.
Sorry for the inconvenience caused.

On Tue, Jun 1, 2021 at 8:50 PM Akshay Joshi <[email-masked]>
wrote:

>>>    - Why you have changed the order of the toolbar button on the
>>>    browser tree? It should not.
>>>
>>>                Changes were related to the wcDocker issue showing
>> reverse order buttons, so had to change in the pgAdmin app to reflect it
>> correctly.
>>
>>>
>>>    - "Please note that the database you are working on has been moved
>>>       or renamed to ${data.actual_db_name}. Refresh databases in browser panel or

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 7 Jun 2021 22:10:00 +0530

On Mon, Jun 7, 2021 at 5:08 PM Rahul Shirsat <[email-masked]>
wrote:

>>>>> Please find the attached patch which resolves the issue of renaming
>>>>> the database by another user.
>>>>>