Subject: [pgAdmin][RM5519]: Unable to close tab after disconnecting server.

From: Pradip Parkale <[email-masked]>
Date: Wed, 31 Mar 2021 19:38:43 +0530

Hi Hackers,
Please find the attached patch for #5519. Updated the existing confirmation
message and also added a new confirmation dialog before closing the query
tool if the server is disconnected.

-- 
Thanks & Regards,
Pradip Parkale
Software Engineer | EnterpriseDB Corporation

---

From: Dave Page <[email-masked]>
Date: Wed, 31 Mar 2021 15:23:36 +0100

Thanks Pradip.

Before this is committed, let's change this:

gettext('Current trasaction is not commited because server is
disconnected.'),

to:

gettext('The current transaction has been rolled back because the server
was disconnected.'),

On Wed, Mar 31, 2021 at 3:09 PM Pradip Parkale <
[email-masked]> wrote:

> Hi Hackers,
> Please find the attached patch for #5519. Updated the existing
> confirmation message and also added a new confirmation dialog before
> closing the query tool if the server is disconnected.
>
> --
> Thanks & Regards,
> Pradip Parkale

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: http://www.enterprisedb.com

---

From: Pradip Parkale <[email-masked]>
Date: Thu, 1 Apr 2021 11:40:00 +0530

Hi Hackers,

Please find the updated patch with the change mentioned by Dave.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 1 Apr 2021 12:14:56 +0530

Thanks, patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*