Subject: [pgAdmin][RM4421] Inno setup script version compare fix

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 2 Jul 2019 13:37:28 +0530

Hi Hackers,

Attached is the patch to fix a potential issue where version compare while
upgrading will be incorrect. Currently, it is comparing strings. So while
comparing '4.9' and '4.10' it will consider '4.9' as greater.
The patch will convert the values to float and compare.

Kindly review.

-- 
Thanks and Regards,
Aditya Toshniwal
Software Engineer | EnterpriseDB India | Pune
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 2 Jul 2019 14:34:42 +0530

Hi Aditya

I have asked Paresh to review the patch, he has given some review comments.
Please fix those and the updated patch asap.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*
*EnterpriseDB Software India Private Limited*
*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 2 Jul 2019 14:51:18 +0530

Hi Hackers,

Attached is the updated patch. Instead of float comparison, string
comparison is done now with the help of a nice article here -
http://www.arvydas.co.uk/2015/04/compare-version-strings-with-innosetup/

Kindly review.

On Tue, Jul 2, 2019 at 2:34 PM Akshay Joshi <[email-masked]>
wrote:

> Hi Aditya
>
> I have asked Paresh to review the patch, he has given some review
> comments. Please fix those and the updated patch asap.
>
>> Attached is the patch to fix a potential issue where version compare
>> while upgrading will be incorrect. Currently, it is comparing strings. So
>> while comparing '4.9' and '4.10' it will consider '4.9' as greater.

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 2 Jul 2019 14:59:12 +0530

Thanks patch applied.

-- 
*Thanks & Regards*
*Akshay Joshi*

*Sr. Software Architect*