Subject: [pgAdmin][RM6398]: Detaching query editor panel gives a blank white panel.

From: Pradip Parkale <[email-masked]>
Date: Wed, 16 Jun 2021 23:28:54 +0530

Hi Hackers,

Please find the attached patch for #6398.Detaching query editor panel gives
a blank white panel.

-- 
Thanks & Regards,
Pradip Parkale
Software Engineer | EnterpriseDB Corporation

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 23 Jun 2021 11:50:06 +0530

Thanks, the patch applied.

On Wed, Jun 16, 2021 at 11:29 PM Pradip Parkale <
[email-masked]> wrote:

> Hi Hackers,
>
> Please find the attached patch for #6398.Detaching query editor panel
> gives a blank white panel.
>
>
> --
> Thanks & Regards,
> Pradip Parkale

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Pradip Parkale <[email-masked]>
Date: Thu, 24 Jun 2021 19:00:28 +0530

Hi Akshay,

Please find attached for debugger and ERD tool which was missing in
my previous patch.

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 24 Jun 2021 19:55:57 +0530

Hi Pradip

I have seen that we have duplicated code for resize_the_queryTool,
resize_the_erdtool, resize_the_psql, and in debugger_ui.js file. I would
suggest making a common function somewhere in the utils and call that
function. In the future, if we need to change the code we will have to
change it in four different places.

Please resend the patch after fixing the above issue.

On Thu, Jun 24, 2021 at 7:00 PM Pradip Parkale <
[email-masked]> wrote:

> On Wed, Jun 23, 2021 at 11:50 AM Akshay Joshi <
> [email-masked]> wrote:
>

---

From: Pradip Parkale <[email-masked]>
Date: Thu, 24 Jun 2021 21:16:29 +0530

Hi Akshay,
Please find the updated patch. I have moved the function into the utility
file now.

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 25 Jun 2021 11:39:56 +0530

On Thu, Jun 24, 2021 at 9:16 PM Pradip Parkale <
[email-masked]> wrote:

> On Thu, Jun 24, 2021 at 7:56 PM Akshay Joshi <

---

From: Pradip Parkale <[email-masked]>
Date: Tue, 6 Jul 2021 15:00:47 +0530

Hi Akshay,
Please find the updated patch.

On Fri, Jun 25, 2021 at 11:40 AM Akshay Joshi <[email-masked]>
wrote:

>>> resize_the_erdtool, resize_the_psql, and in debugger_ui.js file. I
>>> would suggest making a common function somewhere in the utils and call that

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 6 Jul 2021 20:07:41 +0530

On Tue, Jul 6, 2021 at 3:00 PM Pradip Parkale <
[email-masked]> wrote:

> On Fri, Jun 25, 2021 at 11:40 AM Akshay Joshi <
>>> Please find the updated patch. I have moved the function into the
>>> utility file now.
>>>
>>>>>>> Please find the attached patch for #6398.Detaching query editor
>>>>>>> panel gives a blank white panel.
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>> Thanks & Regards,
>>>>>>> Pradip Parkale