Subject: [pgAdmin4][Patch]: Fixed default public IP range issue in AWS deployment

From: Khushboo Vashi <[email-masked]>
Date: Fri, 11 Mar 2022 08:49:39 +0530

Hi,

Please find the attached patch to fix the default Public IP range issue in
AWS deployment.

@Yogesh Mahajan <[email-masked]>, please test.

Thanks,
Khushboo

---

From: Yogesh Mahajan <[email-masked]>
Date: Fri, 11 Mar 2022 09:21:24 +0530

Hi,

Patch looks fine. IP Addresses are prefixed by 32 and 128 for IPv4 and IPv6
respectively.

Thanks,
Yogesh Mahajan
EnterpriseDB

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 11 Mar 2022 10:11:32 +0530

Hi Khushboo

Why there are two identical functions (def get_my_ip) in two different
files, can you please make it generic in one place only and send the patch.

On Fri, Mar 11, 2022 at 9:22 AM Yogesh Mahajan <
[email-masked]> wrote:

> Hi,
>
> Patch looks fine. IP Addresses are prefixed by 32 and 128 for IPv4 and
> IPv6 respectively.
>
> Thanks,
> Yogesh Mahajan
> EnterpriseDB
>
>
>> Please find the attached patch to fix the default Public IP range issue
>> in AWS deployment.
>>

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Khushboo Vashi <[email-masked]>
Date: Fri, 11 Mar 2022 11:56:25 +0530

One is for pgacloud standalone code for background process and one for
pgadmin module.

---

From: Dave Page <[email-masked]>
Date: Fri, 11 Mar 2022 07:18:22 +0000

> Patch looks fine. IP Addresses are prefixed by 32 and 128 for IPv4 and

I hope you mean suffixed, not prefixed :-)

-- 
Dave Page
https://pgsnake.blogspot.com

EDB Postgres
https://www.enterprisedb.com

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 11 Mar 2022 14:12:48 +0530

Isn't it possible to define it at a common location? These types of
duplicate code are error-prone since sometimes we fix an issue at one place
and forget to fix it at another.

---

From: Akshay Joshi <[email-masked]>
Date: Fri, 11 Mar 2022 14:34:12 +0530

Thanks, the patch applied

On Fri, Mar 11, 2022 at 2:12 PM Akshay Joshi <[email-masked]>
wrote:

>>>>> Please find the attached patch to fix the default Public IP range
>>>>> issue in AWS deployment.
>>>>>