Subject: pgAdmin4 v9.0 candidate builds

From: Akshay Joshi <[email-masked]>
Date: Mon, 3 Feb 2025 15:22:13 +0530

Hi All,

pgAdmin4 v9.0 candidate builds and source code is available at
https://developer.pgadmin.org/builds/2025-02-03-1/

Yogesh, could you please verify this for Thursday's release?

Akshay Joshi

Principle Software Architect

enterprisedb.com

*  Blog*: https://www.enterprisedb.com/akshay-joshi
*  GitHub*: https://github.com/akshay-joshi
*  LinkedIn*: https://www.linkedin.com/in/akshay-joshi-086497216

---

From: Usman Khan <[email-masked]>
Date: Tue, 4 Feb 2025 20:48:17 +0500

Hi,
I will test on following

   - ubuntu 24.04
   - windows 11

I will update my status before EOD tomorrow.

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 4 Feb 2025 21:27:58 +0530

Hi Usman

Please hold off until tomorrow—we’ve made some changes and need to do a
respin. I’ll update you as soon as the new installers are ready for testing

---

From: Usman Khan <[email-masked]>
Date: Tue, 4 Feb 2025 21:25:13 +0500

sure, thanks for the update.

On Tue, Feb 4, 2025 at 8:58 PM Akshay Joshi <[email-masked]>
wrote:

>> On Mon, Feb 3, 2025 at 2:52 PM Akshay Joshi <
>> [email-masked]> wrote:
>>
>>> Hi All,
>>>

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 5 Feb 2025 12:29:56 +0530

Hi All,

pgAdmin4 v9.0 latest candidate builds and source code is available at
https://developer.pgadmin.org/builds/2025-02-05-1/

---

From: Usman Khan <[email-masked]>
Date: Wed, 5 Feb 2025 15:40:00 +0500

Hi,
I will verify the following
1. ubuntu 24.04
2. windows 11

On Wed, Feb 5, 2025 at 12:00 PM Akshay Joshi <[email-masked]>
wrote:

>> On Tue, Feb 4, 2025 at 8:58 PM Akshay Joshi <

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 5 Feb 2025 16:13:29 +0530

Hi All,

Fixed one more issue for the Windows installer. The latest candidate builds
and source code is available at
https://developer.pgadmin.org/builds/2025-02-05-2/
<https://developer.pgadmin.org/builds/2025-02-05-2/>

---

From: Usman Khan <[email-masked]>
Date: Wed, 5 Feb 2025 15:48:38 +0500

The link does not contain the .exe installer, can you please verify.

.

On Wed, Feb 5, 2025 at 3:43 PM Akshay Joshi <[email-masked]>
wrote:

> Hi All,
>
> Fixed one more issue for the Windows installer. The latest
> candidate builds and source code is available at
> On Wed, Feb 5, 2025 at 12:29 PM Akshay Joshi <

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 5 Feb 2025 16:22:27 +0530

> The link does not contain the .exe installer, can you please verify.

    It's there can you please refresh.

>>>>> Please hold off until tomorrow—we’ve made some changes and need to do
>>>>> a respin. I’ll update you as soon as the new installers are ready for
>>>>> testing
>>>>>

---

From: Usman Khan <[email-masked]>
Date: Wed, 5 Feb 2025 15:54:29 +0500

Looks good now.

On Wed, Feb 5, 2025 at 3:52 PM Akshay Joshi <[email-masked]>
wrote:

>> On Wed, Feb 5, 2025 at 3:43 PM Akshay Joshi <

---

From: Usman Khan <[email-masked]>
Date: Wed, 5 Feb 2025 19:36:33 +0500

Hi Hackers,

I have performed basic sanity on the following platforms
1. ubuntu 24.04
2. windows 11

I did not encounter any issue. The list of test cases performed on each
platform are also attached here.

On Wed, Feb 5, 2025 at 3:54 PM Usman Khan <[email-masked]> wrote:

>>>>>>> Please hold off until tomorrow—we’ve made some changes and need to
>>>>>>> do a respin. I’ll update you as soon as the new installers are ready for
>>>>>>> testing
>>>>>>>

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 5 Feb 2025 20:41:47 +0530

Hi All,

Electron's latest version fails to start on RHEL 8/Rocky 8, so we must pin
the version to "33.3.2".

The latest candidate builds, and source code is available at
https://developer.pgadmin.org/builds/2025-02-05-3/

---

From: Usman Khan <[email-masked]>
Date: Thu, 6 Feb 2025 11:31:43 +0500

Hi Hackers,
I have reverified the following platforms
1. ubuntu 24.04
2. windows 11
No issue found at my end.

On Wed, Feb 5, 2025 at 8:12 PM Akshay Joshi <[email-masked]>
wrote:

>> On Wed, Feb 5, 2025 at 3:52 PM Akshay Joshi <

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 6 Feb 2025 16:19:59 +0530

Hi All,

Encountered another critical issue on Ubuntu 20: 'Python v3.8 does not
support parenthesized context expressions,' which is causing migrations to
fail.
The latest candidate builds and source code is available at
https://developer.pgadmin.org/builds/2025-02-06-1/

On Thu, Feb 6, 2025 at 12:01 PM Usman Khan <[email-masked]> wrote:

>> Electron's latest version fails to start on RHEL 8/Rocky 8, so we must
>> pin the version to "33.3.2".
>>
>>>>>>> pgAdmin4 v9.0 latest candidate builds and source code is available
>>>>>>> at https://developer.pgadmin.org/builds/2025-02-05-1/
>>>>>>>

---

From: Zaid Shabbir <[email-masked]>
Date: Thu, 6 Feb 2025 16:05:14 +0500

Thanks Akshay for the update.

Is there any dashboard or matrix where I can locate the package
verification status on different supported platforms ?

Regards,
Zaid Shabbir

On Thu, Feb 6, 2025 at 3:50 PM Akshay Joshi <[email-masked]>
wrote:

>> On Wed, Feb 5, 2025 at 8:12 PM Akshay Joshi <
>>>>>>>>>> Please hold off until tomorrow—we’ve made some changes and need
>>>>>>>>>> to do a respin. I’ll update you as soon as the new installers are ready for
>>>>>>>>>> testing
>>>>>>>>>>
>>>>>>>>>>>> *  LinkedIn*:
>>>>>>>>>>>> https://www.linkedin.com/in/akshay-joshi-086497216
>>>>>>>>>>>>
>>>>>>>>>>>

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 6 Feb 2025 16:53:16 +0530

Hi Zaid

Currently, we don't have a public dashboard or matrix for updating the
status. However, if there's a need for one in the future, we can certainly
create it.

---

From: Yogesh Mahajan <[email-masked]>
Date: Thu, 6 Feb 2025 17:55:29 +0530

Hi Akshay,

One round of installer testing is completed. pgAdmin version 9.0 can be
released.

Thanks,
Yogesh Mahajan
EnterpriseDB