Subject: [Patch] Bug #4256 - ALTER DEFAULT PRIVILEGES FOR ROLE some_role REVOKE EXECUTE ON FUNCTIONS FROM PUBLIC:

From: Yogesh Mahajan <[email-masked]>
Date: Mon, 28 Feb 2022 18:03:06 +0530

Hi Team,

Please find a patch which fixes sql for alter default privileges.

Thanks,
Yogesh Mahajan
EnterpriseDB

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 28 Feb 2022 18:23:57 +0530

Hi Aditya

Can you please review it?

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 1 Mar 2022 12:50:07 +0530

Hi Yogesh,

The original bug is not fixed with the patch. You might have fixed the
related ones.

-- 
Thanks,
Aditya Toshniwal
pgAdmin Hacker | Software Architect | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Yogesh Mahajan <[email-masked]>
Date: Mon, 28 Mar 2022 16:42:19 +0530

Hello Team,

Please find the updated patch which fixes sql revoke statements shown for
databases.

Thanks,
Yogesh Mahajan
EnterpriseDB

On Tue, Mar 1, 2022 at 12:50 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Mon, Feb 28, 2022 at 6:24 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Aditya
>>

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 28 Mar 2022 17:37:41 +0530

Thanks, the patch applied

---

From: Yogesh Mahajan <[email-masked]>
Date: Tue, 29 Mar 2022 14:52:03 +0530

Hello,

Please find the attached patch which fixes resql test failures due to the
above patch.

Thanks,
Yogesh Mahajan
EnterpriseDB

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 29 Mar 2022 14:58:36 +0530

Thanks, the patch applied.

On Tue, Mar 29, 2022 at 2:52 PM Yogesh Mahajan <
[email-masked]> wrote:

> On Mon, Mar 28, 2022 at 5:37 PM Akshay Joshi <
>>> Please find the updated patch which fixes sql revoke statements shown
>>> for databases.
>>>
>>>
>>> Thanks,
>>> Yogesh Mahajan
>>> EnterpriseDB
>>>
>>>