Subject: pgAdmin 4 commit: 1) Added email id validation on the login page.

From: Akshay Joshi <[email-masked]>
Date: Fri, 11 Sep 2020 14:37:17 +0000

1) Added email id validation on the login page.
2) Added validation for the file manager.

Branch
------
master

Details
-------
https://git.postgresql.org/gitweb?p=pgadmin4.git;a=commitdiff;h=b82e6dbdb8646de0bd35c7297f81a32dee5d1891
Author: Aditya Toshniwal <[email-masked]>

Modified Files
--------------
web/pgadmin/authenticate/internal.py          | 15 +++++++----
web/pgadmin/misc/file_manager/__init__.py     | 37 ++++++++++++---------------
web/pgadmin/setup/user_info.py                | 10 +++-----
web/pgadmin/tools/user_management/__init__.py | 22 +++++++++++-----
web/pgadmin/utils/paths.py                    | 19 +++++++++++---
web/pgadmin/utils/validation_utils.py         | 26 +++++++++++++++++++
6 files changed, 86 insertions(+), 43 deletions(-)

---

From: Murtuza Zabuawala <[email-masked]>
Date: Wed, 16 Sep 2020 14:52:36 +0530

Hi Team,

PFA patch to fix typo introduced with this patch.

--
Regards,
Murtuza Zabuawala
*EDB*
*POWER TO POSTGRES*
https://www.edbpostgres.com

---

From: Akshay Joshi <[email-masked]>
Date: Thu, 17 Sep 2020 20:23:14 +0530

Thanks, patch applied.

On Wed, Sep 16, 2020 at 2:52 PM Murtuza Zabuawala <
[email-masked]> wrote:

> On Fri, Sep 11, 2020 at 8:07 PM Akshay Joshi <
> [email-masked]> wrote:
>

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*