Subject: [pgAdmin][RM5488] Tooltip information does not display properly if user check all options under explain analyze

From: Aditya Toshniwal <[email-masked]>
Date: Mon, 11 Jan 2021 16:37:34 +0530

Hi Hackers,

Attached patch improves the way explain plan details tooltip for a node is
shown. With the change, popup with details will be shown upon clicking a
node, and it will remain open until explicitly closed.

Please review.

-- 
Thanks,
Aditya Toshniwal
pgAdmin hacker | Sr. Software Engineer | *edbpostgres.com*
<http://edbpostgres.com>
"Don't Complain about Heat, Plant a TREE"

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 12 Jan 2021 14:51:13 +0530

Hi Aditya

Code looks good to me. Below are the review comments:

   - Copy and Paste not working in the popup.
   - Documentation needs to be updated.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Aditya Toshniwal <[email-masked]>
Date: Tue, 12 Jan 2021 16:08:03 +0530

Hi Akshay,

Attached is the updated patch. Please review.

On Tue, Jan 12, 2021 at 2:51 PM Akshay Joshi <[email-masked]>
wrote:

>> Attached patch improves the way explain plan details tooltip for a node
>> is shown. With the change, popup with details will be shown upon clicking a

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 12 Jan 2021 16:45:35 +0530

Thanks, patch applied.

On Tue, Jan 12, 2021 at 4:08 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Tue, Jan 12, 2021 at 2:51 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Aditya
>>

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 20 Jan 2021 16:37:14 +0530

Hi Hackers,

Attached patch:
1) Fixes the broken explain GUI test case.
2) Displays a tooltip "Click for details..." on hover over explain plan
nodes.

Please review.

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 20 Jan 2021 18:10:17 +0530

Thanks, patch applied.

On Wed, Jan 20, 2021 at 4:37 PM Aditya Toshniwal <
[email-masked]> wrote:

> On Tue, Jan 12, 2021 at 4:45 PM Akshay Joshi <
>>>>> Attached patch improves the way explain plan details tooltip for a
>>>>> node is shown. With the change, popup with details will be shown upon
>>>>> clicking a node, and it will remain open until explicitly closed.
>>>>>
>>>>> Please review.
>>>>>
>>>>> --
>>>>> Thanks,
>>>>> Aditya Toshniwal