Subject: pgAdmin4: Test-suite OS compatability issue

From: Navnath Gadakh <[email-masked]>
Date: Fri, 28 Apr 2017 19:21:32 +0530

Hi Dave,

         Please find the patch for OS compatability issue of test-suite.

*Code Changes:*

            1. Minor code changes done related to os module in
*pgadmin4/web/regression/feature_utils/app_starter.py*
            2. Code added in
pgadmin4/*web/pgadmin/utils/tests/test_versioned_template_loader.py
*to handle path for SQL file.
            3. Code added to convert unicode to string in some .py files.

*Note:*
             With python2.6.6 test-suite is failed to execute. I have
created the RM 2367 <https://redmine.postgresql.org/issues/2367>

Thank you!

-- 
Regards,
Navnath Gadakh

EnterpriseDB Corporation
The Enterprise PostgreSQL Company

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Dave Page <[email-masked]>
Date: Tue, 2 May 2017 12:09:55 +0100

Hi

When testing on Mac, the testsuite never exits with this patch applied. It
just hangs after printing the result summary.

On Fri, Apr 28, 2017 at 2:51 PM, Navnath Gadakh <
[email-masked]> wrote:

>             2. Code added in pgadmin4/*web/pgadmin/utils/tests/test_versioned_template_loader.py

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Navnath Gadakh <[email-masked]>
Date: Wed, 3 May 2017 11:43:31 +0530

Hi Dave,

         I have applied and run this patch on Mac and it ran successfully
without hang up.

I used different OS:
       OS X Yosemite Version 10.10.2
       OS X EI Capitan Version 10.11.6

What is your system config?

-- 
Regards,
Navnath Gadakh

EnterpriseDB Corporation

---

From: Dave Page <[email-masked]>
Date: Wed, 3 May 2017 09:09:27 +0100

10.12.3 (Sierra), 16GB MBP. Running in a virtualenv built from the system
Python installation. Packages are:

(pgadmin4)piranha:~ dpage$ pip freeze
alabaster==0.7.10
alembic==0.9.1
args==0.1.0
Babel==1.3
beautifulsoup4==4.4.1
blinker==1.3
chromedriver-installer==0.0.6
click==6.6
clint==0.5.1
dateutils==0.6.6
docutils==0.13.1
extras==1.0.0
fixtures==3.0.0
Flask==0.11.1
Flask-Babel==0.11.1
Flask-Gravatar==0.4.2
Flask-HTMLmin==1.2
Flask-Login==0.3.2
Flask-Mail==0.9.1
Flask-Migrate==2.0.3
Flask-Principal==0.4.0
Flask-Script==2.0.5
Flask-Security==1.7.5
Flask-SQLAlchemy==2.1
Flask-WTF==0.12
html5lib==1.0b3
htmlmin==0.1.10
imagesize==0.7.1
importlib==1.0.3
itsdangerous==0.24
Jinja2==2.7.3
linecache2==1.0.0
Mako==1.0.6
MarkupSafe==0.23
minify==0.1.4
passlib==1.6.2
pbr==2.0.0
pkginfo==1.4.1
psycopg2==2.6.2
pycrypto==2.6.1
Pygments==2.2.0
pyperclip==1.5.27
pyrsistent==0.12.1
python-dateutil==2.5.0
python-editor==1.0.3
python-mimeparse==1.6.0
pytz==2014.10
requests==2.13.0
requests-toolbelt==0.7.1
selenium==3.3.1
simplejson==3.6.5
six==1.10.0
snowballstemmer==1.2.1
speaklater==1.3
Sphinx==1.5.3
SQLAlchemy==1.0.14
sqlparse==0.1.19
testscenarios==0.5.0
testtools==2.0.0
traceback2==1.4.0
unittest2==1.1.0
Werkzeug==0.9.6
WTForms==2.0.2

On Wed, May 3, 2017 at 7:13 AM, Navnath Gadakh <
[email-masked]> wrote:

>> When testing on Mac, the testsuite never exits with this patch applied.
>> It just hangs after printing the result summary.
>>

---

From: Navnath Gadakh <[email-masked]>
Date: Wed, 3 May 2017 18:02:31 +0530

It's getting strange now. I just updated my Mac OS from EI Capitan(10.11.6)
to Sierra(10.12.4). I have applied the patch and it ran successfully
without any hangup.

This is my console output:

*======================================================================*

*Test Result Summary*

*======================================================================*

*REGRESSION TEST 1 PostgreSQL 9.6:*

*140 tests passed*

*0 test failed*

*16 tests skipped:*

*PackageAddTestCase (Fetch Package Node URL)*

*PackageDeleteTestCase (Fetch Package Node URL)*

*PackageGetTestCase (Fetch Package Node URL)*

*PackagePutTestCase (Fetch Package Node URL)*

*SynonymAddTestCase (Default Node URL)*

*SynonymDeleteTestCase (Fetch synonym Node URL)*

*SynonymGetTestCase (Fetch synonym Node URL)*

*SynonymPutTestCase (Fetch synonym Node URL)*

*ResourceGroupsAddTestCase (Add resource groups)*

*ResourceGroupsDeleteTestCase (Delete resource groups)*

*ResourceGroupsPutTestCase (Put resource groups)*

*ResourceGroupsGetTestCase (Get resource groups)*

*TableSpaceAddTestCase (Check Tablespace Node)*

*TableSpaceDeleteTestCase (Check Tablespace Node)*

*TablespaceGetTestCase (Check Tablespace Node)*

*TableSpaceUpdateTestCase (Check Tablespace Node)*

*======================================================================*

*Please check output in file:
/Users/edb/Navnath/pgadmin4/web/regression/regression.log*

*(pgenv36) Laptop227-pn-in:regression Navnath$ *

-- 
Regards,
Navnath Gadakh

EnterpriseDB Corporation

---

From: Dave Page <[email-masked]>
Date: Thu, 4 May 2017 09:48:59 +0100

I still see the issue. See the attached screenshot. Killing process 32287
caused the test suite to exit.

On Wed, May 3, 2017 at 1:32 PM, Navnath Gadakh <
[email-masked]> wrote:

>>>          I have applied and run this patch on Mac and it ran
>>> successfully without hang up.
>>>
>>> I used different OS:

---

From: Navnath Gadakh <[email-masked]>
Date: Thu, 4 May 2017 17:23:02 +0530

Hi Dave,

        Please find the revised patch. I have added some print statements
for debug purpose, so that I can get which line causing this issue. Most
probably issue should be in the cleanup process.

Please apply the patch and run the regression. Send me your console output
and *regression.log* file

Thanks!

On Thu, May 4, 2017 at 2:18 PM, Dave Page <[email-masked]> wrote:

>>> 10.12.3 (Sierra), 16GB MBP. Running in a virtualenv built from the
>>> system Python installation. Packages are:
>>>
>>>>> When testing on Mac, the testsuite never exits with this patch
>>>>> applied. It just hangs after printing the result summary.
>>>>>

-- 
Regards,
Navnath Gadakh

EnterpriseDB Corporation

---

From: Dave Page <[email-masked]>
Date: Thu, 4 May 2017 13:16:02 +0100

Hi

Relevant console output is here, and the console log is attached. Again,
the pgAdmin4.py remained running (pid 39809). Killing it returned control
to the terminal.

Regression - PG 9.4:

144 tests passed
0 tests failed
12 tests skipped:
SynonymGetTestCase (Fetch synonym Node URL)
PackageDeleteTestCase (Fetch Package Node URL)
ResourceGroupsGetTestCase (Get resource groups)
SynonymDeleteTestCase (Fetch synonym Node URL)
ResourceGroupsAddTestCase (Add resource groups)
PackagePutTestCase (Fetch Package Node URL)
SynonymPutTestCase (Fetch synonym Node URL)
ResourceGroupsPutTestCase (Put resource groups)
ResourceGroupsDeleteTestCase (Delete resource groups)
SynonymAddTestCase (Default Node URL)
PackageAddTestCase (Fetch Package Node URL)
PackageGetTestCase (Fetch Package Node URL)

======================================================================

Please check output in file:
/Users/dpage/git/pgadmin4/web/regression/regression.log

Deleting servers.
Deleting servers.
Deleting servers.
Deleting servers.
Deleting servers.
Deleting servers.
Deleting servers.
Deleting servers.
Deleting servers.
Deleting servers.
Deleting servers.
Deleting servers.
Deleting servers.
Stopping app.
I am in stop_app() function.
Quitting driver.
pgAdmin4.py process killed.

On Thu, May 4, 2017 at 12:53 PM, Navnath Gadakh <
[email-masked]> wrote:

>>>>>>>              With python2.6.6 test-suite is failed to execute. I
>>>>>>> have created the RM 2367
>>>>>>> <https://redmine.postgresql.org/issues/2367>
>>>>>>>
>>>>>>> Thank you!
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>> Regards,
>>>>>>> Navnath Gadakh
>>>>>>>
>>>>>>> EnterpriseDB Corporation

---

From: Navnath Gadakh <[email-masked]>
Date: Fri, 5 May 2017 16:05:59 +0530

Hi Dave,

          Please find the revised patch with some code changes related OS
module used in feature tests for starting and stoping the app. There are
some functions of of OS module not supported in windows and unix/mac I have
applied some checked in the code.

Hope this will successfully run on your machine. :)

Thank you.

On Thu, May 4, 2017 at 5:46 PM, Dave Page <[email-masked]> wrote:

> Please check output in file: /Users/dpage/git/pgadmin4/web/
> regression/regression.log
>
> Deleting servers.
> Deleting servers.
> Deleting servers.
> Deleting servers.
> Deleting servers.
> Deleting servers.
> Deleting servers.
> Deleting servers.
> Deleting servers.
> Deleting servers.
> Deleting servers.
> Deleting servers.
> Deleting servers.
> Stopping app.
>> Please apply the patch and run the regression. Send me your console
>> output and *regression.log* file
>>
>> Thanks!
>>
>>
>>
>>
>>
>>
>>> I still see the issue. See the attached screenshot. Killing process
>>> 32287 caused the test suite to exit.
>>>

-- 
Regards,
Navnath Gadakh

EnterpriseDB Corporation

---

From: Dave Page <[email-masked]>
Date: Mon, 8 May 2017 09:26:14 +0100

That seems better - committed, thanks!

On Fri, May 5, 2017 at 11:35 AM, Navnath Gadakh <
[email-masked]> wrote:

>>>         Please find the revised patch. I have added some print
>>> statements for debug purpose, so that I can get which line causing this
>>> issue. Most probably issue should be in the cleanup process.
>>>