Subject: [pgAdmin][RM5330]: [Code Coverage] Improve API test cases for Functions

From: Nikhil Mohite <[email-masked]>
Date: Tue, 22 Sep 2020 10:56:30 +0530

Hi Team,

I have added few more test cases for the "Functions" module as per RM-5330
<https://redmine.postgresql.org/issues/5330>
PFA patch.

-- 
*Thanks & Regards,*
*Nikhil Mohite*
*Software Engineer.*
*EDB Postgres* <https://www.enterprisedb.com/>
*Mob.No: +91-7798364578.*

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 22 Sep 2020 11:41:29 +0530

Hi Nikhil

Test cases are failing for all the database server with the following error:
    return True, sql.strip('\n')
AttributeError: 'tuple' object has no attribute 'strip'

Please check and resend the patch.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Nikhil Mohite <[email-masked]>
Date: Tue, 22 Sep 2020 12:44:31 +0530

Hi Akshay/Team,

I checked the code and found an issue in the "msql" function, due to which
test cases were failing.
I have fixed the issue, PFA updated patch for the same.
Sorry for the inconvenience.

Regards,
Nikhil Mohite.

On Tue, Sep 22, 2020 at 11:41 AM Akshay Joshi <[email-masked]>
wrote:

>> I have added few more test cases for the "Functions" module as per
>> RM-5330 <https://redmine.postgresql.org/issues/5330>
>> PFA patch.
>>
>> --
>> *Thanks & Regards,*
>> *Nikhil Mohite*
>> *Software Engineer.*

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 22 Sep 2020 17:02:29 +0530

Thanks, patch applied

On Tue, 22 Sep, 2020, 12:44 Nikhil Mohite, <[email-masked]>
wrote:

> On Tue, Sep 22, 2020 at 11:41 AM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Nikhil
>>