Subject: [pgAdmin][RM-7149]: [React] Port preferences dialog to React.

From: Nikhil Mohite <[email-masked]>
Date: Mon, 7 Mar 2022 17:53:57 +0530

Hi Hackers,

Please find attached the patch for RM-7149
<https://redmine.postgresql.org/issues/7149>: [React] Port preferences
dialog to React.

-- 
*Thanks & Regards,*
*Nikhil Mohite*
*Senior Software Engineer.*
*EDB Postgres* <https://www.enterprisedb.com/>
*Mob.No: +91-7798364578.*

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 9 Mar 2022 17:47:52 +0530

Hi Nikhil

Below are the review comments:
*GUI:*

   - By default, all nodes should be expanded, and at least one node should
   be selected (Check existing behavior).
   - Reduce the space between the expand/collapse (>) icon and the
   tress node label. It is most likely icons that are taking up that space.
   - Unable to select parent node. With old behavior when we select the
   parent node its immediate first child is selected and the appropriate page
   is displayed on the right side.
   - The maximize button should be consistent with all other dialogs.
   - Maximize not working properly, move the dialog bit up, and then click
   Maximize button, dialog is not visible correctly.
   - The help button is missing at the bottom.
   - A documentation update is missing.
   - Keyboard Shortcuts (Browser, Debugger, Query Tool, and ERD Tool) *Fix
   for all*
      - Between the 'Key' label and control, there should be a margin.
      - Reduce the width of the key control.
      - The key control loses focus when the key is pressed. Verify old
      behavior.
   - Nodes: Can we add a message or label at the top about settings?
   Previously, we had a switch control with a 'Show/Hide' label that was clear
   to the end-user.
   - Dashboard -> Display -> Long-running query thresholds:
      - Between the 'Warning'/'Alert' label and their control, there should
      be a margin.
      - There is no '*in minutes*' label at the end.
   - Miscellaneous -> Themes: Themes preview is not visible.
   - Binary Paths:
      - 'Set as default' should be disabled until a path is provided.
      - 'Set as default' must be a radio button, only one binary path can
      be set to default not all.
      - Unable to select binary path as select dialog is hidden behind the
      preferences dialog. It seems the preferences dialog is the modal dialog.
      - Adjust the validation icon properly, space should not be there at
      the end.
      - 
   - Query Tool: CSV/TXT Output node should be after Auto completion.
   - Browser -> Tab settings and Storage -> Options have identical right
   side page. Remove the controls appropriately.

*Code:*

   - Add comments/function header for all the new functions created.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 21 Mar 2022 13:31:37 +0530

Thanks, the patch applied. Screenshots are still not the latest. Take all
the screenshots with the latest changes and send them back.

On Mon, Mar 21, 2022 at 10:00 AM Nikhil Mohite <
[email-masked]> wrote:

> Hi Akshay,
>
> PFA patch v2 resolved all the review comments.
>
> On Wed, Mar 9, 2022 at 5:48 PM Akshay Joshi <[email-masked]>
> wrote:
>
>> Hi Nikhil
>>
>>    - By default, all nodes should be expanded, and at least one node
>>    should be selected (Check existing behavior).
>>    - Maximize not working properly, move the dialog bit up, and then
>>    click Maximize button, dialog is not visible correctly.
>>       - Between the 'Warning'/'Alert' label and their control, there
>>       should be a margin.
>>       - 'Set as default' must be a radio button, only one binary path
>>       can be set to default not all.
>>       - Unable to select binary path as select dialog is hidden behind
>>       the preferences dialog. It seems the preferences dialog is the modal dialog.
>>       - Adjust the validation icon properly, space should not be there
>>       at the end.
>>       - 
>>  I tried but was unable to reproduce the issue.
>
>>
>> *Code:*
>>
>> On Mon, Mar 7, 2022 at 5:54 PM Nikhil Mohite <
>> [email-masked]> wrote:
>>
>>> Hi Hackers,
>>>
> Regards,
> Nikhil Mohite

---

From: Nikhil Mohite <[email-masked]>
Date: Wed, 23 Mar 2022 12:14:52 +0530

Hi Akshay,

Please find the updated patch, resolved the following issues in the
preferences dialog.

   1. Add server mode validation in the binary path.
   2. Updated preferences tree rendering to avoid using the ReactDOM render.
   3. Updated CSS for keyboard shortcuts checkbox border makes it
   consistent with input box border.
   4. Fixed jasmine test case and improved code coverage.
   5. Fixed sonarqube issues.
   6. Added validation to disable "*Maximum column with" option *if "*Column
   **sized by" option *is set to *"Column name"* in *Query Tool -> Result
   grid*.
   7. Updated documentation with the latest screenshots.
   8. Updated documentation to fix issue #7261
   <https://redmine.postgresql.org/issues/7261>: Typo on the document.

On Mon, Mar 21, 2022 at 1:31 PM Akshay Joshi <[email-masked]>
wrote:

>> On Wed, Mar 9, 2022 at 5:48 PM Akshay Joshi <
>> [email-masked]> wrote:
>>
>>> Hi Nikhil
>>>
>>>    - Browser -> Tab settings and Storage -> Options have identical
>>>    right side page. Remove the controls appropriately.
>>>
Regards,
Nikhil Mohite

---

From: Nikhil Mohite <[email-masked]>
Date: Tue, 29 Mar 2022 15:35:55 +0530

Hi Akshay,

PFA updated patch resolved the following issues in the preferences dialog:

   1. Show a single note in the binary path.
   2. Resolved issue in the keyboard shortcut.

On Wed, Mar 23, 2022 at 12:14 PM Nikhil Mohite <
[email-masked]> wrote:

> On Mon, Mar 21, 2022 at 1:31 PM Akshay Joshi <
>>>>    - Unable to select parent node. With old behavior when we select
>>>>    the parent node its immediate first child is selected and the appropriate
>>>>    page is displayed on the right side.
>>>>       - The key control loses focus when the key is pressed. Verify
>>>>       old behavior.
>>>>> <https://redmine.postgresql.org/issues/7149>: [React] Port
>>>>> preferences dialog to React.
>>>>>
>>>>> --
>>>>> *Thanks & Regards,*
>>>>> *Nikhil Mohite*

Regards,
Nikhil Mohite

---

From: Nikhil Mohite <[email-masked]>
Date: Fri, 1 Apr 2022 17:28:57 +0530

Hi Akshay,

PFA patch to fix the issue with maximize button on preferences dialog.

On Tue, Mar 29, 2022 at 3:35 PM Nikhil Mohite <
[email-masked]> wrote:

>>    **sized by" option *is set to *"Column name"* in *Query Tool ->
>>    Result grid*.
>>> Thanks, the patch applied. Screenshots are still not the latest. Take
>>> all the screenshots with the latest changes and send them back.
>>>
>>>>>       - Unable to select binary path as select dialog is hidden
>>>>>       behind the preferences dialog. It seems the preferences dialog is the modal
>>>>>       dialog.
>>>>>       - Adjust the validation icon properly, space should not be
>>>>>       there at the end.
>>>>>       - 

Regards,
Nikhil Mohite

---

From: Akshay Joshi <[email-masked]>
Date: Sun, 3 Apr 2022 12:33:40 +0530

Thanks, the patch applied.

On Fri, Apr 1, 2022 at 5:29 PM Nikhil Mohite <[email-masked]>
wrote:

>>>>>>    - Keyboard Shortcuts (Browser, Debugger, Query Tool, and ERD
>>>>>>    Tool) *Fix for all*
>>>>>>       - 'Set as default' must be a radio button, only one binary
>>>>>>       path can be set to default not all.