Subject: [pgAdmin4][RM4232]: Change what is shown by default in tab titles

From: Nikhil Mohite <[email-masked]>
Date: Tue, 13 Oct 2020 17:26:50 +0530

Hi Team,

Regarding RM-4232 <https://redmine.postgresql.org/issues/4232> Change what
is shown by default:
Added placeholders in preferences as following:
1. Debugger: Added placeholder in the display section of the debugger.
2. Query Tool and View/Edit data: Added placeholder in the display section
of the Query Tool.

Updated the documentation for Query Tool and Debugger with new screenshots.

PFA patch.

-- 
*Thanks & Regards,*
*Nikhil Mohite*
*Software Engineer.*
*EDB Postgres* <https://www.enterprisedb.com/>
*Mob.No: +91-7798364578.*

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 19 Oct 2020 10:58:05 +0530

Hi Nikhil

Following are the review comments:

   - Jasmin test cases are failing.
   - Can we change the following strings in preferences:
      - "Query tool tab title placeholder" to "Query tool tab title"
      - "View/Edit tab title placeholder" to "View/Edit data tab title"
      - "Debugger tab title placeholder" to "Tab title" as this setting is
      already inside the Debugger section.
   - Change the help messages in the preferences dialog to:
      - "*Supported placeholders are %DATABASE%, %USERNAME%, and %SERVER%.
      Users can provide any string with or without placeholders of
their choice.
      The blank title will be revert back to the default title with
placeholders.*"
      (Make the same changes for Query tool, View/Edit, and Debugger tab title
      message)
   - For Debugger can we add %ARGS% because in the case of functions with
   arguments tab title is very long, so the user should have the option to
   discard arguments in the tab title.

Update the documentation if you will make the above changes.

On Tue, Oct 13, 2020 at 5:27 PM Nikhil Mohite <
[email-masked]> wrote:

> Hi Team,
>
> Regarding RM-4232 <https://redmine.postgresql.org/issues/4232> Change
> what is shown by default:

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Sr. Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Nikhil Mohite <[email-masked]>
Date: Tue, 20 Oct 2020 09:07:45 +0530

Hi Akshay,

I have resolved the review comments and also added a %ARGS% placeholder for
the debugger.
PFA patch v2.

Regards,
Nikhil Mohite.

On Mon, Oct 19, 2020 at 10:58 AM Akshay Joshi <[email-masked]>
wrote:

>       - "Debugger tab title placeholder" to "Tab title" as this setting
>       is already inside the Debugger section.
>       - "*Supported placeholders are %DATABASE%, %USERNAME%, and
>       %SERVER%. Users can provide any string with or without placeholders of
>       their choice. The blank title will be revert back to the default title with
>       placeholders.*" (Make the same changes for Query tool, View/Edit,
>       and Debugger tab title message)
>> 2. Query Tool and View/Edit data: Added placeholder in the display
>> section of the Query Tool.
>>

---

From: Akshay Joshi <[email-masked]>
Date: Tue, 20 Oct 2020 17:18:29 +0530

Thanks, patch applied.

On Tue, Oct 20, 2020 at 9:07 AM Nikhil Mohite <
[email-masked]> wrote:

> Hi Akshay,
>
> I have resolved the review comments and also added a %ARGS% placeholder
> for the debugger.
> PFA patch v2.
>
> Regards,
> Nikhil Mohite.
>
> On Mon, Oct 19, 2020 at 10:58 AM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Nikhil
>>
>>    - For Debugger can we add %ARGS% because in the case of functions
>>    with arguments tab title is very long, so the user should have the option
>>    to discard arguments in the tab title.
>>