Subject: [pgAdmin][RM-6984]: Port Backup Global, Backup Server and Backup object dialog in React

From: Nikhil Mohite <[email-masked]>
Date: Wed, 10 Nov 2021 11:29:55 +0530

Hi Hackers,

Please find the attached patch for RM-6884:
<https://redmine.postgresql.org/issues/6984>  Port Backup Global, Backup
Server, and Backup object dialog in React

-- 
*Thanks & Regards,*
*Nikhil Mohite*
*Senior Software Engineer.*
*EDB Postgres* <https://www.enterprisedb.com/>
*Mob.No: +91-7798364578.*

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 17 Nov 2021 18:34:32 +0530

Hi Nikhil

Following are the review comments:

GUI:

   - Dialog size should be increased.
   - Remove the first blank element from the Encoding dropdown.
   - When opening the file dialog header should have the title 'Select
   file'.
   - 'Backup server' title should be changed to 'Backup Server'.
   - When taking the backup of any object like database, schema, etc..
   the title on the dialog header should be "Backup (Database/Schema ..."
   instead of  "Backup (database/schema ..."

Code:

   - Jasmine test cases are failing.
   - Remove warnBeforeChangesLost function not needed for Utilities.
   (Remove Alertify as well)
   - The naming convention should be identical, in some cases, you used
   camel case and in some cases used with an underscore.
   - Remove the commented code from all the files.
   - Take all the screenshots again with a width of 681.

Note: I haven't tested it thoroughly with all combinations.

-- 
*Thanks & Regards*
*Akshay Joshi*
*pgAdmin Hacker | Principal Software Architect*
*EDB Postgres <http://edbpostgres.com>*

*Mobile: +91 976-788-8246*

---

From: Nikhil Mohite <[email-masked]>
Date: Mon, 22 Nov 2021 10:48:36 +0530

Hi Akshay,

Please find the updated patch.

On Wed, Nov 17, 2021 at 6:34 PM Akshay Joshi <[email-masked]>
wrote:

> Resolved all review comments.

---

From: Akshay Joshi <[email-masked]>
Date: Mon, 22 Nov 2021 11:21:57 +0530

Thanks, the patch applied.

On Mon, Nov 22, 2021 at 10:48 AM Nikhil Mohite <
[email-masked]> wrote:

> On Wed, Nov 17, 2021 at 6:34 PM Akshay Joshi <
> [email-masked]> wrote:
>
>> Hi Nikhil
>>
>>> <https://redmine.postgresql.org/issues/6984>  Port Backup Global,
>>> Backup Server, and Backup object dialog in React
>>>
>>>
>>
>> --
>> *Thanks & Regards*
>> *Akshay Joshi*

---

From: Nikhil Mohite <[email-masked]>
Date: Wed, 24 Nov 2021 17:09:14 +0530

Hi Akshay,

Please find the updated patch:
1. Resolved issue if the binary patch is not present/ not correct, then
show error notification to add/ correct the binary path.

Regards,
Nikhil Mohite

---

From: Akshay Joshi <[email-masked]>
Date: Wed, 24 Nov 2021 17:30:05 +0530

On Wed, Nov 24, 2021 at 5:09 PM Nikhil Mohite <
[email-masked]> wrote:

> On Mon, Nov 22, 2021 at 11:22 AM Akshay Joshi <
>>>>    - The naming convention should be identical, in some cases, you
>>>>    used camel case and in some cases used with an underscore.