Subject: [PATCH] Add Commit/Rollback toolbar action version 2

From: John Obaterspok <[email-masked]>
Date: Sun, 13 Sep 2015 21:37:58 +0200

Hello,

I'm updated the patch to add commit/rollback actions in the toolbar with
the following:
1) updated icons (based on existing pgadmin icon with arrows drawn by me)
2) add entry to menu as well
3) disable icons when not in a transaction
4) Ctrl+Shift C|R shortcut

Hopefully all issues are resolved now!

Regards,

          John

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Ashesh Vashi <[email-masked]>
Date: Mon, 14 Sep 2015 13:12:30 +0530

Sanket,

Can you please take a look at it?

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>

---

From: Sanket Mehta <[email-masked]>
Date: Mon, 14 Sep 2015 14:21:30 +0530

Sure Ashesh,

I will review the patch.

Regards,
Sanket Mehta
Sr Software engineer
Enterprisedb

On Mon, Sep 14, 2015 at 1:12 PM, Ashesh Vashi <[email-masked]

> On Mon, Sep 14, 2015 at 1:07 AM, John Obaterspok <
> [email-masked]> wrote:
>
>> Hello,
>>

---

From: Sanket Mehta <[email-masked]>
Date: Wed, 16 Sep 2015 11:20:27 +0200

Hi John,

Patch is not proper.
I got below error when I try to apply the patch:

error: patch failed: pgadmin/frm/frmQuery.cpp:2435
error: pgadmin/frm/frmQuery.cpp: patch does not apply

Please do provide the proper patch.

Regards,
Sanket Mehta
Sr Software engineer
Enterprisedb

On Mon, Sep 14, 2015 at 10:51 AM, Sanket Mehta <
[email-masked]> wrote:

> Sure Ashesh,
>
> I will review the patch.
>
> Regards,
> Sanket Mehta
> Sr Software engineer
> Enterprisedb
>
> On Mon, Sep 14, 2015 at 1:12 PM, Ashesh Vashi <
> [email-masked]> wrote:
>
>> Sanket,
>>

---

From: John Obaterspok <[email-masked]>
Date: Wed, 16 Sep 2015 20:27:26 +0200

Hi Sanket,

Attached patch is rebased now.

Regards,

-- john

2015-09-16 11:20 GMT+02:00 Sanket Mehta <[email-masked]>:

>>>> I'm updated the patch to add commit/rollback actions in the toolbar
>>>> with the following:

---

From: John Obaterspok <[email-masked]>
Date: Wed, 23 Sep 2015 07:38:59 +0200

Hi Sanket,

Did you give the patch a try? I would really like it to for the next
release :)

-- john

---

From: Sanket Mehta <[email-masked]>
Date: Wed, 23 Sep 2015 13:19:23 +0530

Hi John/Ashesh,

I have reviewed the patch and it seems fine to me.

Regards,
Sanket Mehta
Sr Software engineer
Enterprisedb

On Wed, Sep 23, 2015 at 11:08 AM, John Obaterspok <[email-masked]

---

From: John Obaterspok <[email-masked]>
Date: Fri, 25 Sep 2015 08:03:24 +0200

Thanks, appreciated.

Can it be committed then? :)

2015-09-23 9:49 GMT+02:00 Sanket Mehta <[email-masked]>:

> On Wed, Sep 23, 2015 at 11:08 AM, John Obaterspok <

---

From: Dave Page <[email-masked]>
Date: Fri, 25 Sep 2015 08:58:19 +0100

Ashesh, are you able to deal with this before Monday (when I'll be cutting
the feature-frozen beta 1 tarballs)?

-- 
Dave Page
Blog: http://pgsnake.blogspot.com
Twitter: @pgsnake

EnterpriseDB UK: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Ashesh Vashi <[email-masked]>
Date: Fri, 25 Sep 2015 13:30:44 +0530

Yup.
It's in my plate, was updating the CHANGELOG only.

--

Thanks & Regards,

Ashesh Vashi

On Fri, Sep 25, 2015 at 1:28 PM, Dave Page <[email-masked]> wrote:

> On Fri, Sep 25, 2015 at 7:03 AM, John Obaterspok <
>>>>> 2015-09-16 11:20 GMT+02:00 Sanket Mehta <[email-masked]
>>>>> >:
>>>>>
>>>>>> Hi John,
>>>>>>
>>>>>> Patch is not proper.
>>>>>>>>> I'm updated the patch to add commit/rollback actions in the
>>>>>>>>> toolbar with the following:

---

From: Ashesh Vashi <[email-masked]>
Date: Fri, 25 Sep 2015 15:51:26 +0530

On Fri, Sep 25, 2015 at 1:30 PM, Ashesh Vashi <[email-masked]

> It's in my plate, was updating the CHANGELOG only.
Done.

Thanks John for the patch, and Sanket for reviewing the patch.

--

Thanks & Regards,

Ashesh Vashi

>> Ashesh, are you able to deal with this before Monday (when I'll be
>> cutting the feature-frozen beta 1 tarballs)?
>>